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GeneSpring GT (Varia analysis workbench) is a genetic analysis 
software tool. Use this manual to install:

• the standalone version of GeneSpringGT 

• the GeneSpring client, if you have the Agilent GeneSpring 
License Manager (GSLM)

Download the GeneSpring (Varia) installation package from our 
Web site: 
http://www.chem.agilent.com/cag/bsp/SiG/Products/2/ 
DemoDownload.asp
Agilent Technologies



NOTE Agilent Technologies acquired Silicon Genetics in 2005. The name of 
Silicon Genetics Varia will be changed to Agilent GeneSpring GT in future 
releases. This document might refer to both Varia and Agilent during this 
transition period.
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System requirements

This section lists the system requirements for Windows and Mac OS machines.

Windows systems

The following are minimum requirements for GeneSpring GT (Varia analysis 
workbench) software:

• Windows XP, 2000, or Server 2003

• 1024 MB RAM

• Pentium IV processor (or equivalent) 

• 2-4 GB disk space (for the complete human or mouse genomes). 

• 1024x768 pixel resolution and 16-bit color. 

Macintosh systems

The following are minimum requirements for GeneSpring GT (Varia analysis 
workbench) software:

• Mac OS X

• 1024 MB RAM

• 250 MB disk space (for GeneSpring (Varia) with the supplied Crohn's 
genome). 

• 2-4 GB disk space (for the complete human or mouse genomes). 

• 1024x768 pixel resolution and 16-bit color strongly recommended. 
Agilent GeneSpring GT 2 (formerly Varia) Installation Guide 3



To upgrade the GeneSpring GT (Varia analysis workbench) Software

If you are migrating from GeneSpring (Varia) Version 1 to Version 2, follow the 
steps in this section.

You do not need to remove the previous install of Varia to run GeneSpring GT 
2. If you want to uninstall GeneSpring GT (Varia), Agilent recommends that 
you run the Uninstaller.exe file provided in the 
..\SiliconGenetics\Uninstaller Data\ directory.

If you are upgrading from an older version, this path is likely to be different 
from the one you originally used. Users who upgrade will not modify any of 
the files in their original installation directory by doing so.  

1 Log in as a user with read/write privileges (such as Administrator on 
Windows systems).

2 Quit any applications you are running.

NOTE In GeneSpring GT (Varia analysis workbench) 1, the default destination directory was 
Program Files\Silicon Genetics\Varia on Windows systems (not available on Mac 
OS). 

In GeneSpring GT (Varia) 2, the default destination directory is ..\Agilent\GeneSpring GT 
(Program Files\Agilent\GeneSpring GT on Windows systems; /Users/<user login 
name>/Agilent/GeneSpring GT on Mac OS X.

Agilent recommends that you use the default directory, Agilent, for Version 2, and keep 
your Silicon Genetics directory as a backup.

NOTE If you renew your license, you do not have to go through the installation process to 
enter your new license info. Instead, when Agilent sends you the licensekey.txt file, 
download it to your GeneSpring GT (Varia) directory (by default, 
..\Agilent\GeneSpring GT\data). Click the GeneSpring GT icon to start the program.

The complete path is Program Files\Agilent\GeneSpring GT\data on Windows 
systems, and /Users/<user login name>/Agilent/GeneSpring GT/data on Mac OS 
X systems.
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3 Do not use the same name for the Varia 1 and GeneSpring GT 2 directories. 
Using the same name for both directories would result in important files 
being overwritten:

• ..Varia\data\variapreferences file 

• ..Varia\data\Programs directory

• ..Varia\data\Script directory

• ..Varia\data\Chron genome directory

• ..Varia\data\Cache directory
4 Use Add-Remove Programs to remove the previous installation of Varia 

software.
5 In your Web browser, go to 

http://www.chem.agilent.com/cag/bsp/SiG/Products/2/ 
DemoDownload.asp

and complete the online form to download GeneSpring GT 2 (Varia). 

6 Download the GeneSpring GT (Varia analysis workbench) software. See 
“Step 1. Download the GeneSpring GT (Varia analysis workbench) 
installation package” on page 10.

7 Complete the installation. See “Step 2. Install GeneSpring GT 2 (Varia 
analysis workbench)” on page 11.

8 If you are using a complete human genome, complete the steps in “To 
upgrade to the Build 35 genome” below.

9 To port your Varia 1 data to GeneSpring GT 2, complete the following steps:

a Copy the Homo Sapiens build 34v2 dbSNP 119 directory from .. 
..\Silicon Genetics\Varia\Data to ..\Agilent\GeneSpring GT\Data.

b Copy the ..Varia\data\variapreferences file to ..\Agilent\GeneSpring 
GT\Data; do not rename the file. Doing this overwrites the newer file, 
but retains the preferences you specified in Version 1.

c Copy and paste all your Version 1 directories, except the Cache 
directory, into the new Agilent directory.

GeneSpring GT 2 creates a new Cache directory when you use the 
product.
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To upgrade to the Build 35 genome

GeneSpring GT 2 includes a more recent build of the human genome, Build 35. 
Users are encouraged to begin using this genome, as it contains a more 
exhaustive list of variations and uses a more recent alignment to describe the 
human sequence.   

Agilent strongly recommends that you do not attempt to transfer data 
generated in build 34 (such as variation lists, samples, experiments, haplotype 
map, and sequence region lists) directly into the Build 35 genome. If you want 
to re-analyze your data using Build 35, re-import your data, starting from the 
raw text files generated from the original genotyping technology.

Several changes in Build 35 make it impossible to compare data generated 
using NCBI Build 34 (in Varia 1) and using Build 35. For example, with the 
new alignment (in Build 35), the physical positions of many SNPs have been 
updated. This means that existing haplotype maps will contain blocks that 
include non-adjacent loci. In other cases, two different SNPs in Build 34 (with 
different RS numbers) have been assigned to the same physical location in 
Build 35. Therefore, the safest method to analyze data in Build 35 is to 
re-import it from raw data files.

NOTE Do not simply export a .zip file from an old genome and drag it into the new genome. 
Instead, import data from the original raw data files. One reason for this is that any 
variations that were in the original data files, but not in the original genome, were 
ignored in that genome. If those variations are available in the new genome, they will 
be included when the user imports the raw data.
Genetic maps appropriate to the genome will be incorporated into new genomes 
Agilent releases.
Pedigrees are an exception to this rule, provided that you remove the links to the old 
samples and replace them with links to new samples.
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Agilent converts each new NCBI build into a format that GeneSpring GT can 
use.

1 Install Build 35 as a new genome. See “Step 5. Download genome data” on 
page 20.

2 If you have modified your previous version of the genome (for example, by 
adding custom variations), transfer the modifications into the new genome. 
You will not need to repeat all of your changes in the new genome.

a Open the genome folder in the ..\Varia\data directory.

b Copy the modifications to Build 34. The name of the file to copy ends 
with _diff.txt.

c Copy the file ending with _diff.txt into the genome folder of the new 
genome. See Figure 2.

d Modify the ..\GeneSpring GT\data\<genome name>\*.genomedef file 
in the new genome.

•Open the new genome’s .genomedef file in a text editor.

•Under the line that begins Variations : , add the following line:

VariationsCustom : <name-of-the-*_diff.txt-file>

For example:  
VariationsCustom : Homo Sapiens Build 33 12.1.2003_diff.txt
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Figure 1 Editing the genomedef file

3 Re-import the original raw data from the old genome into the new genome.
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Figure 2 Preparing to re-import data from the old genome into the new genome

4 You will need to recreate the results of analyses (such as Haplotyped Data, 
variation lists, and sequence regions), using the “new” data. See the Varia 
Analysis Workbench User’s Guide.

NOTE If any of the variations have changed location (and many do in new assembly builds), 
the results of the analyses on the same data (with no new variations) will still be 
different. 
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Step 1. Download the GeneSpring GT (Varia analysis workbench) 
installation package

1 Open your Web browser and copy the following URL into the URL field: 
http://www.chem.agilent.com/cag/bsp/SiG/Products/2/ 
DemoDownload.asp

2 Complete the online form and click Submit.

To clear the form and start over, click Reset.

3 Download the GeneSpring GT2_0 Installer, and proceed to “Step 2. Install 
GeneSpring GT 2 (Varia analysis workbench)” below. 
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Step 2. Install GeneSpring GT 2 (Varia analysis workbench)

By default, the GeneSpring GT (Varia analysis workbench) installation 
program installs three items in the main directory (..\Agilent) on Windows 
systems, and two items on Mac OS X systems: 

• A GeneSpring GT folder: contains such files as the installation program, 
sample data, and help files. 

• A GeneSpring_GT_InstallLog.xml file, which summarizes the install 
process

• Windows only: A Java folder (gsgtjre): contains Java-related files and 
libraries. (A java folder is not included with the GeneSpringGT for 
Macintosh installer because Mac OS X already has its own java—Apple’s 
Java 1.4.2_09.)

The default destination directory is Program Files\Agilent\GeneSpringGT 
on Windows systems; /Users/<user login name>/Agilent/GeneSpringGT on 
Mac OS X.

1 Make sure you are logged on as a user with read/write privileges (such as 
Administrator on Windows systems).

2 Make sure your system meets the minimum requirements listed in “System 
requirements” on page 3.

3 Close all applications, and run GeneSpring GT.exe.
4 The installation program displays an introductory page. Click Next.
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Figure 3 The introductory GeneSpring GT (Varia analysis workbench) installation page.

5 Read the terms of the license agreement. Click I accept... or I do not 
accept... You must accept the terms of the license agreement in order to 
continue with installation.

6 Click Next.
7 Read the Version Notes/Important Info page, and click Next until the 

installer displays the Choose Install Folder page.

NOTE Macintosh users: Be sure to read items 4 and 5 in the Version Notes.
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Figure 4 The Version Notes page.

8 Specify where the system should install the GeneSpring (Varia) software.

• Agilent recommends that you accept the default location (on Windows: 
C:\Program Files\Agilent. On Mac OS: /Users/<user login 
name>/Agilent/GeneSpringGT).

• To specify a different location, click Choose.

• To reinstate the default location, click Restore Default Folder.
9 Click Next. 
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10 Review the Pre-Installation Summary page. 

Figure 5 The Pre-Installation Summary page.

• If the information is correct, click Install.

• If the information is not correct, click Previous as many times as necessary 
and make the appropriate changes.

11 After installing GeneSpring, the installer displays the Version Notes page 
again (Figure 4 on page 13). Click Next.

12 The next installer page asks if you would like to view the QuickStart Guide. 
Click Yes or No and then click Next

13 The installer displays a reminder for you to download a genome. This is 
optional, but most users do so. 

NOTE You can click on the Web link in the installer to download a genome. However, if you do 
so, you must complete the GeneSpringGT installation when you are finished 
downloading the genome. 
See “Step 5. Download genome data” on page 20 for information about downloading a 
genome.
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14 Click Done on the Install Complete page of the installer.

The system launches GeneSpring (Varia) automatically.

15 Enter license information. See “Step 3. Enter license information” on 
page 16.

16 GeneSpring GT (Varia) displays a Helpful Hint dialog box. Click OK to 
continue without reading the hints, and Details to read them.

17 Select the genome to open. If you have not downloaded a complete genome, 
select Crohns Mini-Genome and click OK.

18 Configure GeneSpring (Varia) for compatibility with your system. Follow 
the steps in “Step 4. Configure GeneSpring GT (Varia analysis workbench)” 
on page 19.

19 If you will be using a complete genome, do one of the following if you have 
not already done so:

a Download the genome data. See “Step 5. Download genome data” on 
page 20.]

b If you are migrating from GeneSpring GT (Varia) Version 1 to Version 2, 
and you are using the human genome, complete the steps in “To upgrade 
to the Build 35 genome” on page 6.
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Step 3. Enter license information

You need to enter Agilent-supplied license information to use GeneSpring GT 
(Varia analysis workbench).

If you downloaded GeneSpring (Varia) on a trial basis, you can use the product 
for one day, but you need to purchase a license to continue to use it.

1 Click the GeneSpring GT icon to start the program, if it is not already 
started.

Figure 6 The GeneSpring GT desktop icon

2 When you start GeneSpring (Varia) for the first time, or before you have a 
permanent license, the system displays the Permanent license entry dialog 
box (Figure 7).

Figure 7 Permanent license entry dialog box

NOTE If you renew your license in order to upgrade from GeneSpring GT Version 1 to Version 
2, you do not have to go through the installation process to enter your new license info. 
Instead, when Agilent sends you the licensekey.txt file, download it to your 
GeneSpring GT (Varia) directory (by default, ..\Agilent\data). 
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3 If you click No, the system displays the Online Demo License Registration 
form (Figure 8). Complete the form, click Submit Registration, and 
continue with step 6.

When you complete this form, Agilent sets up a temporary license for you, 
and automatically makes it permanent when you purchase the license. You 
do not need to enter a separate “permanent license” later.

Figure 8 Online demo license registration form
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4 If you click Yes, the system displays the Enter License dialog box 
(Figure 9).

Figure 9 The Enter License dialog box.

5 Open the licensekey.txt file. Paste the entire contents of licensekey.txt into 
the top text box in the Enter License dialog box.

The ID Number field displays your computer’s Ethernet address. 

6 The GeneSpring (Varia) program starts, and prompts you to select a genome 
to open. Select the desired genome and click OK. 

If you have any problems getting a license to run GeneSpring GT (Varia), 
contact Agilent technical support (sig_support@agilent.com) and provide 
them the information (including ID Number field) in step 5 above.
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Step 4. Configure GeneSpring GT (Varia analysis workbench)

Change the memory preferences

GeneSpring GT (Varia) installation assumes you have the required resources 
to run the program, as specified on the Agilent GeneSpring Web site. Agilent 
recommends that you use the default value, but if you need to increase the 
memory, follow these steps.

1 Double-click the GeneSpring GT icon to start the GeneSpring GT (Varia 
analysis workbench) program.

2 Choose Edit > Preferences.
3 Click the System tab.
4 Set the value in Desired Memory Use to the desired value. Agilent 

recommends that you use the default value (700 MB), or set it to about 2/3 
of your available RAM.

5 Click Apply or OK.

Figure 10 The System tab, where you can specify memory resources for GeneSpring 
(Varia).

To further optimize performance, you can edit the Java heap size (Windows: 
Program Files\Agilent\GeneSpring GT\varia.lax). Contact Agilent 
technical support (sig_support@agilent.com) if you want to do this step.
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Step 5. Download genome data 

This install package includes variation data from a small section of Human 
Chromosome 5 that was used to study Crohn's disease. The installation also 
includes a small section of sequence that spans the region in question. Agilent 
provides sample genome data in the installation package, rather than a 
complete genome, to let you download GeneSpring (Varia) quickly.

Most users will want to download NCBI Build 35 of the complete human 
genome (the complete human sequence, and the complete list of variations). 
This file is available from the Agilent Web FTP site using the same password 
you used to download this install package. You can also download the NCBI 
Build 32 of the complete mouse genome at the Agilent Web FTP site.

If you want to download a different genome, contact your Agilent 
representative.

1 Open a Web browser, and enter the following URL in the address field: 
http://www.chem.agilent.com/Scripts/Generic.ASP?lPage=35399 

NOTE If you are migrating from GeneSpring GT Version 1 to 2, do not follow the instructions in 
this section; instead, follow the instructions in “To upgrade to the Build 35 genome” on 
page 6.

NOTE The genome data files for GeneSpring GT (Varia analysis workbench) are very large 
(about 1 GB). Be aware that the data might take a long time to download.
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2 Double-click the genome (human or mouse) that you want to download.

Figure 11 Part of the Agilent FTP site for downloading genomes

3 Specify where you want to download the .zip file.
4 Download the genome.
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Figure 12 Downloading a genome

5 Open GeneSpring GT (Varia). In the GeneSpring GT (Varia) window, do one 
of the following:

a Select File > Import Varia Zip

b Drag the genome .zip file into the GeneSpring GT (Varia) window.
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Figure 13 Importing a genome into GeneSpring GT (Varia)

6 The system displays a confirmation dialog box. Click Yes if you are sure you 
want to import the specified .zip file into the current genome, or No to 
cancel the import.

Figure 14 Genome upgrade confirmation dialog box

7 After importing the genome, the system prompts you to close GeneSpring 
GT (Varia). Click OK.

8 Start GeneSpring (Varia) again. If GeneSpring (Varia) does not prompt you 
to select a genome upon startup, select File > Open Genome or Array, and 
select the name of the genome you just imported.
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Figure 15 Selecting a genome to open

9 GeneSpring GT (Varia) loads the genome.
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To uninstall GeneSpring GT or Varia analysis workbench)

• To uninstall Varia 1, run Uninstaller.exe, located in the 
..\SiliconGenetics\Uninstaller Data directory.

• To uninstall GeneSpring GT 2:

• On Windows systems, run the Uninstall GeneSpring GT.exe file 
provided in the ..\Agilent\GeneSpring GT\Uninstaller Data directory. 

• On Mac OS X systems, double-click Uninstall GeneSpring GT in the 
/Users/<user login name>/Agilent/GeneSpringGT/UninstallerData 
folder.

Contacting Agilent Technical Support

If you need technical support, contact Agilent at sig_support@agilent.com.

To expedite the support process, follow these steps:

Windows users

1 From the GeneSpring (Varia) main window, select Help > About.
2 Take a screenshot of the splash screen, making sure to note:

• the license serial number

• the operating system

• the current JVM that GeneSpring (Varia) is using
3 Exit GeneSpring (Varia).
4 Use Notepad to open Program Files\Agilent\Varia\varia.lax.
5 Scroll to the line lax.stderr.redirect=
6 Set this value to console.
7 Scroll to the line lax.stdout.redirect=
8 Set this value to console.
9 Save and exit the varia.lax file.
10 Restart GeneSpring (Varia). See if you can reproduce your problem with the 

console running.
11 Take a screenshot of the console if stack traces or exceptions are thrown.
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Macintosh users

1 From the GeneSpring (Varia) main window, select Help > About.
2 Take a screenshot of the splash screen, making sure to note:

• the license serial number

• the operating system
3 Exit GeneSpring (Varia).
4 In the /Users/<user login name>/Agilent/GeneSpring GT/data folder, 

right-click the GeneSpringGT executable icon.
5 Select Show Package Contents, and open the Contents folder.
6 Open the Info.plist file with TextEdit (right-click Info.plist and select 

TextEdit). TextEdit is in the Mac OS /Applications folder.
7 Scroll to the line stderr.redirect=
8 Set this value to console.
9 Scroll to the line stdout.redirect=
10 Set this value to console.
11 Save and exit the Info.plist file.
12 Restart GeneSpringGT (Varia). See if you can reproduce your problem with 

the console running.
13 Take a screenshot of the console if stack traces or exceptions are thrown.
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