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PICkit™ 2 用户指南

前言
简介

本章包含使用 PICkit™ 2 单片机编程器前需要了解的关于本用户指南和客户支持的一
般信息。内容包括：

• 文档编排

• 本指南使用的约定

• 保修登记

• 推荐读物

• Microchip 网站

• 开发系统变更通知客户服务

• 客户支持

• 文档版本历史

• 疑难解答

文档编排

本文档介绍了如何使用 PICkit™ 2 单片机编程器。本手册的内容编排如下：

• 第 1 章：PICkit™ 2 概述——PICkit™ 2 单片机编程器的概述。

• 第 2 章：入门——说明如何开始使用 PICkit™ 2 单片机编程器对基于闪存的
PICmicro® 单片机 （Microcontroller Unit， MCU）进行编程。

• 第 3 章： PICkit™ 2 和 ICSP™——说明如何使用在线串行编程 （In-Circuit Serial 
Programming™， ICSP™）通过 PICkit™ 2 单片机编程器进行编程。

• 第4章： 更新PICkit™ 2操作系统——说明如何更新PICkit™ 2单片机编程器的操作
系统。

用户须知

所有文档均会过时，本文档也不例外。 Microchip 的工具和文档将不断演变以满足客户的需求，因此
实际使用中有些对话框和 / 或工具说明可能与本文档所述之内容有所不同。请访问我们的网站
（www.microchip.com）获取最新文档。

文档均标记有 “DS”编号。该编号出现在每页底部的页码之前。 DS 编号的命名约定为
“DSXXXXXA”，其中 “XXXXX”为文档编号，“A”为文档版本。

欲了解开发工具的最新信息，请参考 MPLAB® IDE 在线帮助。从 Help （帮助）菜单选择 Topics
（主题），打开现有在线帮助文件列表。
 2005 Microchip Technology Inc. DS51553A_CN 第1 页



PICkit™ 2 用户指南
• 第 5 章： 疑难解答——对使用 PICkit™ 2 单片机编程器过程中遇到的常见问题提供
解决方法。

• 附录 A：硬件原理图——提供 PICkit™ 2 单片机编程器的硬件原理图。 

本指南使用的约定

本手册采用以下文档约定：

文档约定

保修登记

请填写随附的保修登记卡 （Warranty Registration Card）并尽快寄出。寄出保修登记
卡的客户将可收到新产品更新信息。临时发布的软件在 Microchip 网站上提供。

说明 涵义 示例

代码 (Courier 字体 )：
常规字符 代码示例

文件名和路径

#define START
c:\autoexec.bat

尖括号： < > 变量 <label>, <exp>

方括号 [ ] 可选参数 MPASMWIN [main.asm]

花括号和竖线： { | } 选择互斥参数； “或”选择 errorlevel {0|1}

引号括起的小写字符 数据类型 "filename"
省略号 ... 用来暗示 （但不显示）与该示例无关

的其他文字

list 
["list_option..., 
"list_option"]

0xnnn 十六进制数， n 是一个十六进制数字 0xFFFF, 0x007A

斜体字 可变参数；可以是数据类型 （小写字
符）或具体示例 （大写字符）。

char isascii (char, 
ch);

界面 (Arial 字体 )：
带右箭头且有下划线的
斜体文字

菜单栏中的菜单选项 File > Save

粗体字 可以单击的窗口或对话框按钮 OK, Cancel
尖括号 < > 括起的字符 键盘上的按键 <Tab>, <Ctrl-C>

文档 (Arial 字体 )：
斜体字 参考书目 MPLAB® IDE User’s Guide
DS51553A_CN 第 2 页  2005 Microchip Technology Inc.



前言
推荐读物

使用 PICkit™ 2 单片机编程器前，建议您先熟悉下列文档。

PICkit 2 Low Pin Count Demo Board User's Guide （DSXXXXX）
要了解如何使用 Microchip Technology 的低引脚数器件 （8 引脚、 14 引脚和 20 引
脚），请查阅此文档。其中包含一系列教程。

MPLAB® IDE, Simulator, Editor User's Guide （DS51025）
要详细了解 MPLAB 集成开发环境 （Integrated Development Environment， IDE）软
件的安装和功能，请查阅此文档。

MICROCHIP 网站

Microchip 网站 （www.microchip.com）为客户提供在线支持。客户可通过该网站方便
地获取文件和信息。只要使用常用的因特网浏览器即可访问。网站提供以下信息：

• 产品支持——数据手册和勘误表、应用笔记和范例程序、设计资源、用户指南以及
硬件支持文档、最新的软件版本以及存档软件

• 一般技术支持——常见问题 （FAQ）、技术支持请求、在线讨论组以及 Microchip
顾问计划成员名单

• Microchip业务——产品选型和订购指南、最新Microchip新闻稿、研讨会和活动安
排表、 Microchip 销售办事处、代理商以及工厂代表列表

开发系统变更通知客户服务

Microchip 的客户通知服务有助于客户了解 Microchip 产品的最新信息。注册客户可在
他们感兴趣的某个产品系列或开发工具发生变更、更新、发布新版本或勘误表时，收
到电子邮件通知。

欲注册，请登录 Microchip 网站 www.microchip.com，点击 “变更通知客户
（Customer Change Notification）”服务并按照注册说明完成注册。

开发系统产品的分类如下：

• 编译器——Microchip C 编译器及其他语言工具的最新信息，包括 MPLAB C18 和
MPLAB C30 C 编译器、 MPASM™ 和 MPLAB ASM30 汇编器、 MPLINK™ 和
MPLAB LINK30 目标链接器，以及 MPLIB™ 和 MPLAB LIB30 目标库管理器。

• 仿真器——Microchip 在线仿真器的最新信息，包括 MPLAB ICE 2000 和 MPLAB 
ICE 4000。

• 在线调试器——Microchip 在线调试器 MPLAB ICD 2 的最新信息。

• MPLAB® IDE——关于支持 Microchip 开发系统工具的 Windows® 集成开发环境 
MPLAB IDE 的最新信息，主要针对 MPLAB IDE、 MPLAB SIM 模拟器、 MPLAB 
IDE 项目管理器以及一般编辑和调试功能。

• 编程器——Microchip编程器的最新信息，包括MPLAB PM3和PRO MATE® II器件
编程器以及 PICSTART® Plus 和 PICkit® 1 开发编程器。
 2005 Microchip Technology Inc. DS51553A_CN 第 3 页
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客户支持

Microchip 产品的用户可通过以下渠道获得帮助：

• 代理商或代表

• 当地销售办事处

• 应用工程师 （FAE）
• 技术支持

• 开发系统信息热线

客户应联系其代理商、代表或应用工程师 （FAE）寻求支持。当地销售办事处也可为
客户提供帮助。本文档后附有销售办事处的联系方式。

也可通过 http://support.microchip.com 获得网上技术支持。

文档版本历史

版本 A （2005 年 5 月）

• 本文档的第一版。

疑难解答

• 请参见第 5 章获取有关常见问题的信息。
DS51553A_CN 第 4 页  2005 Microchip Technology Inc.
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第 1 章  PICkit™ 2 概述
1.1 简介

本章简要介绍了 PICkit™ 2 单片机编程器，并说明了 PICkit™ 2 单片机编程器的特性
和菜单功能。

1.2 重点

本章内容包括：

• PICkit™ 2 内容

• PICkit™ 2 概述

• PICkit™ 2 编程软件

1.3 PICkit™ 2 单片机编程器内容

PICkit™ 2 单片机编程器工具包包含以下组件：

1. PICkit™ 2 单片机编程器

2. USB 电缆

3. PICkit™ 2 Starter Kit CD ROM

1.4 PICkit™ 2 单片机编程器简介

PICkit™ 2 单片机编程器是一款低成本开发编程器。它能够对 Microchip 的大多数闪存
单片机编程。要了解支持的具体产品，请参见 PICkit™ 2 Starter Kit CD ROM 中的
README文件。

通过编程软件可轻松地升级 PICkit™ 2 单片机编程器操作系统 （固件）。通过更新操
作系统可增加对新器件的支持。最新固件可从 Microchip 网站 www.microchip.com 获
取。

注： PICkit™ 2 单片机编程器旨在用于开发编程。对于生产编程，请选用
MPLAB PM3 编程器，或者其他为生产环境设计的第三方编程器。
 2005 Microchip Technology Inc. DS51553A_CN 第5 页
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1.5 PICkit™ 2 单片机编程器概述

图 1-1 中显示了 PICkit™ 2 单片机编程器的全貌。

图 1-1： PICkit™ 2 单片机编程器

1.5.1 USB 端口连接

此 USB 端口连接为 USB 微型 B 连接器。请使用附带的 USB 电缆将 PICkit™ 2 单片机
编程器连接到 PC。

1.5.2 状态 LED
状态 LED 可指示 PICkit™ 2 单片机编程器的状态。

1. Power （绿色）——PICkit™ 2 单片机编程器已通过 USB 端口上电。

2. Target （黄色）——PICkit™ 2 单片机编程器正在向目标器件供电。

3. Busy （红色）——PICkit™ 2 单片机编程器正忙于处理某项功能，比如处于
“编程”模式，或者提示某项功能正在进行中。

1.5.3 按钮

此按钮用于启用某项功能，目前尚未实现。

1

2

4

3

56

图例：

1 －状态 LED 3 －挂绳连接 5 －引脚 1 标记

2 －按钮 4 － USB 端口连接 6 －编程连接器
DS51553A_CN 第 6 页  2005 Microchip Technology Inc.



PICkit™ 2 概述
1.5.4 编程连接器

编程连接器是一个 6 引脚连接器 （0.100" 间距），用于连接到目标器件。引脚排列规
范，请参见图 1-2。引脚 1 用三角形来指示。

要进一步了解如何通过 PICkit™ 2 单片机编程器进行在线串行编程，请参见第 3
章 “PICkit™ 2 和 ICSP™”。

图 1-2： PICkit™ 2 连接器引脚排列

1.5.5 挂绳连接

您可以很方便地将挂绳或吊线穿入挂绳孔，以避免 PICkit™ 2 单片机编程器丢失。

引脚说明

1 － VPP/MCLR
2 － VDD 目标电源

3 － VSS （地）

4 － ICSPDAT/PGD
5 － ICSPCLK/PGC
6 － AUX

1
2
3
4
5
6

注： 此连接器为 6 引脚插头，间距为 0.100"，可连接 0.025" 的方形引脚。
 2005 Microchip Technology Inc. DS51553A_CN 第 7 页
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1.6 编程软件

选择开始 > 程序 > PICkit 2 Microcontroller Programmer > PICkit 2，启动 PICkit™ 2 编
程软件。编程界面如图 1-3 所示。

要进一步了解如何使用 PICkit™ 2 编程软件，请参见第 2 章 “入门”。

图 1-3： PICkit™ 2 编程软件

菜单栏

状态条
进度条

程序存储器

器件配置

数据 EEPROM 存储器
DS51553A_CN 第 8 页  2005 Microchip Technology Inc.



PICkit™ 2 概述
1.6.1 菜单栏

在菜单栏中可选择 PICkit™ 编程软件的各种功能。
以下是对这些功能的概括说明：

FILE （文件）

Import File——导入用于编程的 hex 文件

Export File——导出从器件读取的 hex 文件

Exit——退出程序 （作用与 Quit 按钮相同）

DEVICE FAMILY （器件系列）

Baseline （12 位内核）——针对低档闪存器件配置编程软件

Mid-range （14 位内核）——针对中档闪存器件配置编程软件

PIC18——针对 PIC18F 闪存器件配置编程软件 （将来的功能，目前灰掉）

PIC18J——针对 PIC18FXXJXX 闪存器件配置编程软件 （将来的功能，目前灰
掉）

dsPIC——针对 dsPIC 闪存器件配置编程软件 （将来的功能，目前灰掉）

PROGRAMMER （编程器）

Read Device——读取程序存储器、数据 EEPROM 存储器、 ID 单元和配置位。

Write Device——写入程序存储器、数据 EEPROM 存储器、 ID 单元和配置位。

Verify——用编程软件中保存的代码校验从目标 MCU 读取的程序存储器、数据
EEPROM 存储器、 ID 单元和配置位。

Erase——执行目标 MCU 的批量擦除。保留 OSCCAL 和带隙值 （Band Gap，
BG）（仅限 PIC12F629/675 和 PIC16F630/676）。

Blank Check——执行程序存储器、数据 EEPROM 存储器、 ID 单元和配置位的空
白检查。

Full Erase （擦除 OSCCAL 和 BG）——执行批量擦除，包括 OSCCAL 和带隙值
（仅限 PIC12F629/675 和 PIC16F630/676）。
Regenerate OSCCAL——重新生成 OSCCAL 值 （仅限 PIC12F629/675 和
PIC16F630/676）。 AUX 线必须连接到 RA4/T1G 引脚。

Set Band Gap Calibration Value——设定带隙值 （仅限 PIC12F629/675 和
PIC16F630/676）。

TOOLS （工具）

Code-Protect Device——允许单片机在以后执行写操作时使用代码保护功能。

Target Power——通过 PICkit™ 2 单片机编程器向目标器件供电。

Check Board——检查与 PICkit™ 2 单片机编程器的通讯情况，并读取目标 MCU
的器件 ID。

Download PICkit 2 Operating System——下载 PICkit™ 2 单片机编程器固件操作
系统。

ABOUT （关于）

点选这个菜单项将显示一个对话框，指示版本和日期。
 2005 Microchip Technology Inc. DS51553A_CN 第 9 页
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1.6.2 器件配置

Device Configuration 窗口显示 Device （PICmicro MCU 器件）、 User ID （用户
ID）、 Configuration Word （配置字）和 Checksum （校验和）。此窗口中还显示
OSCCAL 和 Band Gap，这两者仅针对 PIC12F629/675 和 PIC16F630/676 器件。

对于中档（14 位内核）器件， PICkit™ 2 单片机编程器读取器件 ID，然后将其显示在
此窗口中。

对于低档 （12 位内核）器件，用户必须从下拉列表框中选择器件。

1.6.3 状态条

状态条以文本显示当前操作的状态。如果操作成功，则状态条会显示绿色背景。如果
操作失败，则状态条会显示红色。如果操作引起警告提示，则状态条会显示黄色。

1.6.4 进度条

进度条显示操作的进度。

1.6.5 程序存储器

选择 File > Import HEX，可以将程序代码加载到 PICkit™ 2 编程软件中；或者单击
Read 按钮可以从器件中读取程序代码。代码的来源显示在 Source 框中。 Program 
Memory 窗口显示十六进制的程序代码。在此窗口中不能编辑代码。

Program Memory 窗口旁边的复选框控制是否将 Program Memory 窗口中显示的代码
烧写到器件中。如果选中此复选框，则 Program Memory 窗口中显示的代码会被烧写
到器件中，并用于校验器件。如果不选中此复选框，则不将 Program Memory 窗口中
显示的代码烧写到器件中，也不将其用于校验器件。

1.6.6 数据 EEPROM 存储器

与上述的程序存储器类似，选择 File > Import HEX 可以将程序代码加载到 PICkit™ 2
编程软件中；或者单击 Read 按钮可以从器件中读取程序代码。代码的来源显示在
Source 框中。 Data EEPROM Memory 窗口显示十六进制的程序代码。在此窗口中不
能编辑代码。

Data EEPROM Memory 窗口旁边的复选框控制是否将 Data EEPROM Memory 窗口中
显示的代码烧写到器件中。如果选中此复选框，则 Data EEPROM Memory 窗口中显
示的代码会被烧写到器件中，并用于校验器件。如果不选中此复选框，则不将 Data 
EEPROM Memory 窗口中显示的代码烧写到器件中，也不将其用于校验器件。
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第 2 章  入门
2.1 简介

本章介绍如何开始使用 PICkit 2 单片机编程器对基于闪存的 PICmicro® 单片机进行编
程。 
要了解如何通过 PICkit 2 单片机编程器进行在线串行编程，请参见第 3 章 “PICkit™ 2
和 ICSP™”。

要了解如何更新 PICkit 2 固件操作系统，请参见第 4 章 “更新 PICkit™ 2 操作系统”。

2.2 安装 PICkit 2 编程软件

将 PICkit™ 2 Starter Kit CD ROM 插入 CD ROM 驱动器。片刻后，将显示介绍性屏
幕。按照屏幕上的指示安装 PICkit™ 2 编程软件。

如果没有出现介绍性屏幕，请浏览至 CD ROM 目录，然后双击 AutorunPro.exe程
序。

2.3 使用 PICkit 2 编程软件

选择开始 > 程序 > PICkit 2 Microcontroller Programmer > PICkit 2，启动 PICkit™ 2 编
程软件。编程界面如图 2-1 所示。

图 2-1： PICkit 2 编程软件
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2.3.1 选择器件系列

PICkit 2 单片机编程器能够对 Microchip 各种基于闪存的 PICmicro® 单片机进行编程。

使用 PICkit 2 单片机编程器的第一步是选择器件系列，方法是单击 Device Family 菜
单，如图 2-2 所示。

图 2-2： 选择器件系列

2.3.2 器件识别

如果选择了中档 （14 位内核）闪存器件系列，则 PICkit 2 单片机编程器会自动从
PICmicro® MCU 中读取器件 ID 字，并将其显示在 Configuration 窗口中，如图 2-3 所
示。

图 2-3： 识别器件

如果选择了低档 （12 位内核）闪存器件系列，则用户必须从器件下拉列表框中选择具
体器件，如图 2-4 所示。

图 2-4： 选择低档闪存器件

警告

请确保选择了正确的低档闪存器件。这些器件不包含用以确认器件选择的器件 ID。如果选择了

错误的低档闪存器件，则可能会导致擦除最后一个存储单元中存储的 OSCCAL 值。
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2.3.3 向目标器件供电

PICkit 2 单片机编程器可向目标器件供电。要向目标器件供电，请选中 Target Power
复选框，如图 2-5 所示。

图 2-5： 使能向目标器件供电

2.3.4 导入 HEX 文件

要导入编译过的程序（hex 文件），请选择 File > Import HEX，如图 2-6 所示。浏览至
hex 文件，然后单击 Open。此时在 Program Memory 和 EE Data Memory 窗口中显示
代码。 hex 文件的名称显示在 Source 框中。

图 2-6： 导入 HEX 文件

注： 启动 PICkit 2 编程软件时，向目标器件供电功能默认为关闭。

警告

USB 端口电流限制设定为 100 mA。如果目标器件和 PICkit 2 单片机编程器的电流之

和超出此电流限制，则 USB 端口将关闭。如果目标器件需要更大电流，则可由外部

电源供电。
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2.3.5 烧写器件

选择器件系列并导入 hex 文件后，单击 Write 按钮，可对目标 PICmicro MCU 进行编
程。此时将擦除 PICmicro MCU 并以之前导入的 hex 代码对其编程。 Device 
Configuration 窗口下面的状态条会显示 “烧写”操作的状态。

如果烧写成功，状态条会变绿并显示 “Write Successful”，如图 2-7 所示。

图 2-7： 成功烧写状态

如果烧写失败，状态条会变红并显示 “Verify failed”，如图 2-8 所示。此错误指示编
程过程中数据被破坏。如果显示此错误，请重新尝试将程序烧写到器件中。如果依然
出错，请参见第 5 章 “疑难解答”，以获取帮助。

图 2-8： 烧写错误状态

注： 编程前将擦除器件。 PICkit 2 单片机编程器使用批量擦除方法，要求 VDD
电压为 4.5 到 5.5V。
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2.3.6 自动重载文件

在每次烧写前，会将导入的 hex 文件的时间戳记与磁盘上的版本进行比较。如果磁盘
上的版本更新，则重新载入此文件。只有在已经从磁盘读取 hex 文件的情况下，才有
此功能。

这个功能可确保将 MPLAB® IDE 编译的最新版本烧写到器件中。

2.3.7 校验

“校验”功能用导入的 hex 文件校验器件中的程序。此功能比较存储器的所有区域，
包括程序存储器、数据 EEPROM 存储器、 ID 和配置位。

要对代码进行校验，请导入 hex 文件并单击 Verify 按钮。如果代码相同，状态条将变
绿并显示“Device Verified”。如果发现不同，状态条将变红并显示出错位置：“Error 
in Program Memory, Data EEPROM Memory, or Configuration Bits”。

2.3.8 读

要查看烧写到 PICmicro MCU 的代码，请单击 Read 按钮。此时在 Program Memory
和 EE Data Memory 窗口中显示代码，以供您查阅。如果显示的全都是零，则此器件
可能被代码保护了。

2.3.9 代码保护器件

“代码保护器件”功能使能 PICmicro MCU 的代码保护功能。要保护代码，请执行以
下步骤：

1. 导入 hex 文件。

2. 选择 Tools > Code Protect Device，如图 2-9 所示。

3. 单击 Write。

图 2-9： 使能代码保护

注： 如果读取已代码保护的器件，则 Program Memory 和 Data EEPROM 
Memory 窗口显示的全都是零。
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2.3.10 擦除

“擦除”功能可以擦除程序存储器、数据 EEPROM 存储器、 ID 和配置位。但是，一
般情况下不需要此功能，因为 “烧写”功能在对 PICmicro MCU 进行编程之前就已执
行擦除操作。

要擦除器件，请单击 Erase 按钮。

注： PICkit 2 单片机编程器使用批量擦除方法，要求 VDD 电压为 4.5 到 5.5V。
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第 3 章  PICkit™ 2 和 ICSP™
3.1 简介

PICkit™ 2 单片机编程器可以对安装在应用电路中的 PICmicro® 单片机进行在线串行编
程。在线串行编程需要五个信号：

• VPP——编程电压；施加此电压时，器件进入编程模式。

• ICSPCLK/PGC——编程时钟；编程器到目标器件的单向同步串行时钟线。

• ICSPDAT/PGD——编程数据；双向同步串行数据线。

• VDD——电源正电压。

• VSS——电源参考地。

但是，必须将应用电路设计为允许所有编程信号连接至 PICmicro 器件，而不会干扰编
程信号。图 3-1 显示了一个典型电路，设计 ICSP 应用电路时，可以此电路为起点。
要成功实现 ICSP 编程，必须遵守以下各节中的注意事项。

图 3-1： 典型的 ICSP™ 应用电路

注： 要详细了解如何对具体器件进行编程，请参见 Microchip 网站
www.microchip.com 提供的器件编程规范。

  1
  2
  3
  4
  5
  6

VPP/MCLR
VDD
VSS
ICSPDAT/PGD
ICSPCLK/PGC
AUX

目标单片机器件

470 Ω*

0.1 µF*

  1
  2
  3
  4

VDD
RA5

VSS

RA4
RA3/MCLR/VPP

  8
  7
  6
  5

PICkit™ 2

+5V

或

+5V

至应用电路

隔离电路：

电阻或肖特基二极管

编程插头

10k*

* 典型值

RA0/ICSPDAT
RA1/ICSPCLK

RA2
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3.2 隔离 VPP/MCLR/ 端口引脚

施加 VPP 电压时，必须考虑到应用电路中的典型 VPP 电压为 +12V。在下列情况下，
这可能是一个需要考虑的问题：

3.2.1 将 VPP 引脚用作 MCLR 引脚时。

根据器件数据手册的建议，应用电路一般与一个上拉电阻 / 电容电路连接。注意不要使
VPP 电压的变化率变慢，而使其超出编程规范中规定的上升时间 （通常为 1 µs）。
如果在 MCLR 引脚连接监控电路或按钮，建议使用肖特基二极管或限流电阻将它们与
VPP 电压隔离，如图 3-1 所示。有关配合 ICSP 使用监控电路的更多信息，请参见应用
笔记 AN820 “System Supervisors in ICSP™ Architectures”（DS00820）。

3.2.2 将 VPP 引脚用作 I/O 端口引脚时。

连接到 I/O 引脚的应用电路可能无法处理 +12V 电压。建议如图 3-1 所示使用肖特基二
极管或限流电阻来隔离此电路。

3.3 隔离 ICSPCLK/PGC 和 ICSPDAT/PGD 引脚

必须将 ICSPCLK/PGC 和 ICSPDAT/PGD 引脚与应用电路隔离，以防止应用电路影响
编程信号。 ICSPCLK/PGC 是编程器到目标器件的单向同步串行编程时钟线。
ICSPDAT/PGD 是双向同步串行编程数据线。

如果设计时允许，请将这些引脚专用于 ICSP。但是，如果应用电路需要使用这些引
脚，就请采用不会改变信号电平和电压变化率的方式来设计电路。根据不同的应用，
隔离电路会有所差异。图 3-1 显示了其中一种隔离电路，它使用串联电阻将 ICSP 信
号与应用电路隔离。
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3.4 VDD

在 ICSP 编程过程中，必须根据器件规范对 PICmicro MCU 供电。一般情况下，将
PICmicro MCU 的电源连接到应用电路的电源。应用电路可由 PICkit 2 单片机编程器或
外部电源供电。需要注意以下几种情况。

3.4.1 应用电路由 PICkit 2 单片机编程器供电。

PICkit 2 单片机编程器的电源电压 （VDD）为 +5V。如果应用电路以不同的电压工作，
则可能需要增加隔离电路，以使两路电压不发生冲突。

3.4.2 应用电路由外部电源供电。

PICkit 2 单片机编程器的电源电压 （VDD）为 +5V。如果应用电路以不同的电压工作，
则可能需要增加隔离电路，以使两路电压不发生冲突。

3.4.3 使用批量擦除时。

某些 PICmicro MCU 器件使用批量擦除功能来擦除程序存储器、数据 EEPROM 存储
器、 ID 单元和配置位。一般情况下，批量擦除功能要求的电源电压 （VDD）为 4.5 到
5.5 V （有关器件的具体要求，请参见器件编程规范）。 
如果将应用电路设计为在不同的电源电压范围内工作，则上述电压范围可能会产生问
题。为了批量擦除 PICmicro MCU，在保护所有电压敏感电路的同时，还必须在应用
电路中考虑到批量擦除电压要求。 

警告

PICkit 2 单片机编程器的电源电压 （VDD）为 +5V。

警告

USB 端口电流限制设定为 100 mA。如果目标器件和 PICkit 2 单片机编程器的电流之

和超出了此电流限制，则 USB 端口将关闭。如果目标器件需要更大电流，则可由外

部电源供电。

警告

PICkit 2 单片机编程器的电源电压 （VDD）为 +5V。
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3.5 VSS

Vss 为电源的参考地，必须与应用电路同电位。

3.6 其他注意事项

最大限度缩短 ICSP 信号的传输距离，方法是尽可能使 ICSP 连接器靠近应用电路
PICmicro MCU。最大限度缩短 PICkit 2 单片机编程器和应用电路 PICmicro MCU 之间
的电缆长度。这样做的目的是使 ICSP 信号保持在电平和电压变化率规范的要求之内，
从而实现成功编程。
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第 4 章  更新 PICkit™ 2 操作系统
4.1 简介

本章介绍如何更新 PICkit™ 2 单片机编程器的操作系统。

4.2 更新 PICkit 2 单片机编程器

要更新 PICkit 2 单片机编程器固件操作系统，请完成以下步骤：

第 1 步 从 Microchip 网站 www.microchip.com 下载最新的 PICkit 2 操作系统。

第 2 步 在菜单中选择 Tools > Download PICKit 2 Operating System，如图 4-1 所
示。

图 4-1： 下载 PICkit 2 操作系统

第 3 步 浏览至保存最新操作系统代码的目录，如图 4-2 所示。

第 4 步 选择 PK2*.hex文件并单击 Open 按钮。

图 4-2： 选择 PICkit 2 操作系统

操作系统 （OS）的更新进度将显示在编程软件的状态条中，同时 PICkit 2 单片机编程
器上的 Busy LED 将闪烁。成功完成更新后，状态条将显示 “Operating System 
Verified”，同时 Busy LED 熄灭。此时操作系统更新完成。
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注：
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第 5 章  疑难解答
5.1 简介

本章介绍使用 PICkit™ 2 单片机编程器时遇到的常见问题及解决方法。

5.2 常见问题

未识别到器件

问题

为什么会接收到 “Insert Device”消息？

回答

请验证是否支持该器件，并且目标 MCU 是否已根据第 3 章“PICkit™ 2 和 ICSP™”
的说明连接至 PICkit™ 2 单片机编程器。

电流超出限制

问题

为什么会在 Microsoft® Windows® 程序中接收到错误消息 “USB Hub Current Limit 
Exceeded”？

回答

请检查电路板中是否有短路现象。

Microsoft® Windows® 驱动程序

问题

将 PICkit™ 2 单片机编程器插到 USB 端口后， Windows® 98 SE 请求提供驱动程序。
驱动程序在哪里？

回答

PICkit™ 2 单片机编程器使用包含在 Windows® 操作系统中的驱动程序。当 Windows® 
98 SE 请求提供驱动程序时，请选择 “搜索设备的最新驱动程序”，然后选择
“Microsoft Windows Update”旁边的复选框并单击“下一步”。Windows 将自动安装
相应的驱动程序。请勿使用 Microchip 的 ICD 2 USB 驱动程序。

校验和读取时返回的内容都是零

问题

单击 Verify 或 Read 按钮时， Program Memory 窗口显示的都是零。问题出在哪里？

回答

器件可能被代码保护了。请确保在 Configuration Word 中没有选择代码保护。
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Microsoft® Windows® 95/98/NT

问题

是否可以在 Windows® 95/98/NT 上运行？

回答

不可以。这些操作系统或者不支持 USB，或者驱动程序与本产品不兼容。
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附录 A  硬件原理图
A.1 简介

本附录包含 PICkit™ 2 单片机编程器的原理图。

图 A-1： PICkit 2 原理图 （第 1 页，共 2 页）
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图 A-2： PICkit 2 原理图 （第 2 页，共 2 页）
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