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限于针对其使用情况、质量、性能、适销性或特定用途的适用
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引起的后果不承担任何责任。如果将 Microchip 器件用于生命

维持和 / 或生命安全应用，一切风险由买方自负。买方同意在
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前言
简介

本章包含在使用 PICkit™ 2 单片机编程器之前需要了解的一般信息。本章讨论的内容
包括：

• 文档编排

• 本指南使用的约定

• 保修登记

• 推荐读物

• Microchip 网站

• 开发系统变更通知客户服务

• 客户支持

• 文档版本历史

客户须知

所有文档均会过时，本文档也不例外。 Microchip 的工具和文档将不断演变以满足客户的需求，因此
实际使用中有些对话框和 / 或工具说明可能与本文档所述之内容有所不同。请访问我们的网站
（www.microchip.com）获取最新文档。

文档均标记有 “DS”编号。该编号出现在每页底部的页码之前。 DS 编号的命名约定为
“DSXXXXXA”，其中 “XXXXX”为文档编号，“A”为文档版本。

欲了解开发工具的最新信息，请参考 MPLAB® IDE 在线帮助。从 Help （帮助）菜单选择 Topics
（主题），打开现有在线帮助文件列表。
 2008 Microchip Technology Inc.  DS51553D_CN 第 1 页



PICkit™ 2 MCU 编程器用户指南
文档编排

本文档介绍如何使用 PICkit™ 2 单片机编程器开发工具在目标电路板上仿真和调试固
件。本手册的内容编排如下：

• 第 1 章 “PICkit™ 2 编程器概述”——提供 PICkit™ 2 单片机编程器的概述。

• 第 2 章“入门”——说明如何开始使用 PICkit™ 2 单片机编程器对基于闪存的 PIC®

单片机 （MCU）进行编程。

• 第 3 章 “PICkit™ 2 编程器和 ICSP™”——说明如何使用在线串行编程
（In-Circuit Serial Programming™， ICSP™）通过 PICkit™ 2 单片机编程器进行编
程。

• 第 4 章 “PICkit™ 2 Debug Express”——提供如何使用 PICkit™ 2 Debug 
Express 调试器程序的教程。 

• 第 5 章 “疑难解答”——提供解决常见问题的信息。 
• 第6章“更新PICkit™ 2编程器操作系统”——说明如何更新PICkit™ 2单片机编程
器的操作系统。

• 附录 A “硬件原理图”——提供 PICkit™ 2 单片机编程器的硬件原理图。
DS51553D_CN 第 2 页   2008 Microchip Technology Inc.



前言
本指南使用的约定

本手册使用如下文档约定：

文档约定

说明 涵义 示例

Arial 字体：

斜体字 参考书目 MPLAB® IDE User’s Guide
需强调的文字 ... 仅有的编译器 ...

首字母大写 窗口 Output 窗口

对话框 Settings 对话框

菜单选项 选择 Enable Programmer
引用 窗口或对话框中的字段名 “Save project before build”
带右尖括号且有下划线的斜体
文字

菜单路径 File>Save

粗体字 对话框按钮 单击 OK
选项卡 单击 Power 选项卡

N‘Rnnnn verilog 格式的数，其中 N 是
数字总数， R 是基数， n 是一
个数字。

4‘b0010, 2‘hF1

尖括号 < > 括起的文字 键盘上的按键 按 <Enter>， <F1>
Courier New 字体：

常规 Courier New 源代码示例 #define START

文件名 autoexec.bat

文件路径 c:\mcc18\h

关键字 _asm, _endasm, static

命令行选项 -Opa+, -Opa-

位值 0, 1

常数 0xFF, ‘A’

斜体 Courier New 可变参数 file.o，其中 file可以是任
一有效文件名

方括号 [ ] 可选参数 mcc18 [options] file 
[options]

花括号和竖线： { | } 选择互斥参数；“或”选择 errorlevel {0|1}

省略号 ... 代替重复文字 var_name [, 
var_name...]

表示由用户提供的代码 void main (void)
{ ...
}

 2008 Microchip Technology Inc.  DS51553D_CN 第 3 页
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保修登记

请填写随附的保修登记卡 （Warranty Registration Card）并尽快寄出。寄出保修登记
卡的用户将可收到新产品更新信息。临时发布的软件在 Microchip 网站上提供。

推荐读物

本用户指南介绍如何使用 PICkit™ 2 单片机编程器。下面列出了其他有用的文档。
Microchip 提供了如下文档，推荐将这些文档作为补充参考资料。

44-Pin Demo Board User’s Guide （DS41296）
要了解如何使用 44 引脚演示板开发工具在目标电路板上仿真和调试固件，请查阅此文
档。

PICkit™ 2 Low Pin Count Demo Board User’s Guide （DS51556）
要了解如何使用 Microchip Technology 的低引脚数器件 （8 引脚、 14 引脚和 20 引
脚），请查阅此文档。其中包含一系列教程。

MPLAB® IDE 用户指南 （DS51519A_CN）

要详细了解 MPLAB® 集成开发环境（Integrated Development Environment， IDE）软
件的安装和功能，请查阅此文档。

MPLAB® IDE 快速入门指南 （DS51281G_CN）

说明如何设置 MPLAB® IDE 软件，并用它创建项目和对器件编程。

MPLAB® IDE 在线帮助

In-Circuit Serial Programmer™(ICSP™) Guide （DS30277）
本文档中的设计指导将帮助您成功进行 ICSP 编程。其中包括硬件设计方面的应用笔
记和 ICSP 编程规范。

MPASM™ 汇编器、 MPLINK™ 目标链接器、 MPLIB™ 目标库管理器用户指南
（DS33014J_CN） 
说明如何使用 Microchip 的 PIC® MCU 汇编器 （MPASM 汇编器）、链接器
（MPLINK 链接器）和库管理器 （MPLIB 库管理器）。

PICkit™ 2 Debug Express 的自述文件

有关使用 PICkit™ 2 Debug Express 的最新信息，请阅读 “Readme for PICkit 
2.htm”文件（ASCII 文本文件），该文件位于 MPLAB® IDE 安装目录的 Readmes 子目
录下。自述文件包含了本用户指南中可能未提供的更新信息和已知问题。

自述文件

有关使用其他工具的最新信息，请阅读与该工具相关的自述文件，文件位于 MPLAB® 
IDE 安装目录的 Readmes 子目录下。自述文件包含本用户指南中可能未提供的更新信
息和已知问题。
DS51553D_CN 第 4 页   2008 Microchip Technology Inc.
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MICROCHIP 网站

Microchip 网站 （www.microchip.com）为客户提供在线支持。客户可通过该网站方便
地获取文件和信息。只要使用常用的因特网浏览器即可访问。网站提供以下信息：

• 产品支持——数据手册和勘误表、应用笔记和示例程序、设计资源、用户指南以及
硬件支持文档、最新的软件版本以及存档软件

• 一般技术支持——常见问题 （FAQ）、技术支持请求、在线讨论组以及 Microchip
顾问计划成员名单

• Microchip业务——产品选型和订购指南、最新Microchip新闻稿、研讨会和活动安
排表、 Microchip 销售办事处、代理商以及工厂代表列表

开发系统变更通知客户服务

Microchip 的客户通知服务有助于客户了解 Microchip 产品的最新信息。注册客户可在
他们感兴趣的某个产品系列或开发工具发生变更、更新、发布新版本或勘误表时，收
到电子邮件通知。

欲注册，请登录 Microchip 网站 www.microchip.com，点击 “变更通知客户
（Customer Change Notification）”服务后按照注册说明完成注册。

开发系统产品的分类如下：

• 编译器——Microchip C 编译器及其他语言工具的最新信息，包括 MPLAB® C18 和
MPLAB® C30 C 编译器、 MPASM™ 和 MPLAB® ASM30 汇编器、 MPLINK™ 和
MPLAB® LINK30 目标链接器，以及 MPLIB™ 和 MPLAB® LIB30 目标库管理器。

• 仿真器——Microchip在线仿真器的最新信息，包括MPLAB® ICE 2000和MPLAB® 
ICE 4000。

• 在线调试器——Microchip 在线调试器 MPLAB® ICD 2 的最新信息。

• MPLAB® IDE——关于支持 Microchip 开发系统工具的 Windows® 集成开发环境
MPLAB® IDE 的最新信息，主要针对 MPLAB® IDE、 MPLAB® SIM 模拟器、
MPLAB® IDE 项目管理器以及一般编辑和调试功能。

• 编程器——Microchip 编程器的最新信息，包括 MPLAB® PM3 和 PRO MATE® II 器
件编程器以及 PICSTART® Plus 和 PICkit™ 开发编程器。
 2008 Microchip Technology Inc.  DS51553D_CN 第 5 页



PICkit™ 2 MCU 编程器用户指南
客户支持

Microchip 产品的用户可通过以下渠道获得帮助：

• 代理商或代表

• 当地销售办事处

• 应用工程师 （FAE）
• 技术支持

客户应联系其代理商、代表或应用工程师 （FAE）寻求支持。当地销售办事处也可为
客户提供帮助。本文档后附有销售办事处的联系方式。

也可通过 http://support.microchip.com 获得网上技术支持。

文档版本历史

版本 A （2005 年 7 月）

• 本文档的初始版本。

版本 B （2006 年 8 月）

• 更新了前言，添加了第 4 章 “PICkit™ 2 Debug Express”教程。

版本 C （2007 年 1 月）

• 更新了第 1-6 章。

• 更新了前言，其中去除了 “客户支持”列表项中的 “开发系统信息热线”。

版本 D （2007 年 8 月）

• 更新了附录 A.1 和 A.2。
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第 1 章  PICkit™ 2 编程器概述
1.1 简介

本章简要介绍了 PICkit™ 2 单片机编程器，并说明了 PICkit™ 2 单片机编程器的特性
和菜单功能。

1.2 重点

本章内容包括：

• PICkit™ 2 单片机编程器内容

• PICkit™ 2 单片机编程器概述

• PICkit™ 2 编程软件

1.3 PICkit™ 2 单片机编程器内容

PICkit™ 2 单片机编程器工具包包含以下组件：

1. PICkit™ 2 单片机编程器

2. USB 电缆

3. PICkit™ Starter Kit CD-ROM

1.4 PICkit™ 2 单片机编程器简介

PICkit™ 2 单片机编程器是一款低成本开发编程器。它能够对 Microchip 的大多数闪存
单片机编程。要了解支持的具体产品，请参见 PICkit™ Starter Kit CD-ROM 中的
README文件。

通过编程软件可轻松地升级 PICkit™ 2 单片机编程器操作系统 （固件）。通过更新操
作系统可增加对新器件的支持。最新固件可从 Microchip 网站 www.microchip.com 获
取。

注： PICkit™ 2 单片机编程器旨在用于开发编程。对于生产编程，请选用
MPLAB® PM3 编程器，或者其他为生产环境设计的第三方编程器。
 2008 Microchip Technology Inc. DS51553D_CN 第 7 页
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1.5 PICkit™ 2 单片机编程器概述

图 1-1 中显示了 PICkit™ 2 单片机编程器的全貌。

图 1-1： PICkit™ 2 单片机编程器

1.5.1 USB 端口连接

此 USB 端口连接为 USB 微型 B 连接器。请使用附带的 USB 电缆将 PICkit™ 2 单片机
编程器连接到 PC。

1.5.2 状态 LED
状态 LED 可指示 PICkit™ 2 单片机编程器的状态。

1. Power （绿色）——PICkit™ 2 单片机编程器已通过 USB 端口上电。

2. Target （黄色）——PICkit™ 2 单片机编程器正在向目标器件供电。

3. Busy （红色）——PICkit™ 2 单片机编程器正忙于处理某项功能，比如处于
“编程”模式，或者提示某项功能正在进行中。

1.5.3 按钮

此按钮用于在选中 Programmer > Write on PICkit Button 时启动 Write Device（烧写器
件）编程功能。 

1

2

4

3

56

图例：

1 －状态 LED 3 －挂绳连接 5 －引脚 1 标记

2 －按钮 4 － USB 端口连接 6 －编程连接器
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1.5.4 编程连接器

编程连接器是一个 6 引脚插头 （0.100" 间距），用于连接到目标器件。引脚排列规
范，请参见图 1-2。 
要进一步了解如何通过 PICkit™ 2 单片机编程器进行在线串行编程 （ICSP™），请参
见第 3 章 “PICkit™ 2 编程器和 ICSP™”。

图 1-2： PICkit™ 2 编程器连接器引脚排列

1.5.5 挂绳连接

您可以很方便地将挂绳穿入挂绳孔，以避免 PICkit™ 2 单片机编程器丢失。

1
2
3
4
5
6

注： 此 6 引脚插头 （0.100" 间距）可连接 0.025" 的方形引脚。

引脚说明

1 = VPP/MCLR
2 = VDD 目标电源

3 = VSS （地）

4 = ICSPDAT/PGD
5 = ICSPCLK/PGC
6 = 备用

引脚 1 指示标记
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1.6 编程软件

选择开始 > 程序 > Microchip > PICkit 2，启动 PICkit™ 2 编程软件。编程界面如图 1-3
所示。

要进一步了解如何使用 PICkit™ 2 编程软件，请参见第 2 章 “入门”。

图 1-3： PICkit™ 2 编程软件

菜单栏

状态窗口

进度条

程序存储器

器件配置

EEPROM 数据存储器

存储器源

器件 VDD
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1.6.1 菜单栏

可在菜单栏中选择 PICkit™ 2 编程软件的各种功能。以下是对这些功能的概括说明：

FILE （文件）

• Import Hex （导入 Hex）——导入用于编程的 hex 文件。支持 hex 文件格式
INHX32。 

• Export Hex（导出 Hex）——导出从器件读取的 hex 文件。hex 文件以 INHX32 格式
创建。

• Exit （退出）——退出程序。

DEVICE FAMILY （器件系列）

选择某一器件系列可搜索该系列中连接的器件。选择当前器件的器件系列会将所有器
件数据清除。 
对部分无法自动检测的系列 （例如低档系列），会出现一个下拉框，从中可以选择支
持的器件。 

PROGRAMMER （编程器）

• Read Device（读器件）——读取程序存储器、数据 EEPROM 存储器、 ID 单元和
配置位。

• Write Device——写入程序存储器、数据 EEPROM 存储器、 ID 单元和配置位。

• Verify（校验）——用编程软件中保存的代码校验从目标 MCU 读取的程序存储器、
数据 EEPROM 存储器、 ID 单元和配置位。

• Erase（擦除）——执行目标 MCU 的批量擦除。保留 OSCCAL 和带隙值（对于具
有这些特性的器件）。

• Blank Check（空白检查）——执行程序存储器、数据 EEPROM 存储器、 ID 单元
和配置位的空白检查。

• Verify on Write （写校验）——选中时，器件会在编程后立即进行写校验 （推
荐）。未选中时，将对器件编程但不进行写校验。 

• Hold Device in Reset （保持器件复位）——选中时， MCLR （VPP）引脚保持低
电平 （拉为低电平）。未选中时，引脚被释放 （三态），外部上拉可使器件脱离复
位状态。 

• Write on PICkit Button（按下 PICkit 按钮时写）——选中时，按下 PICkit 2 按钮将
启动写操作。 

TOOLS （工具）

• Enable Code Protect （使能代码保护）——允许单片机在以后执行写操作时使用
代码保护功能。

• Enable Data Protect （使能数据保护）——允许单片机在以后对数据 EEPROM 存
储器执行写操作时使用数据保护功能。 

• Set OSCCAL（设置 OSCCAL）——对于将 OSCCAL 值存储在最后一个程序存储
单元的器件，允许修改 OSCCAL 值。

• Target VDD Source （目标 VDD 源） >
- Auto-Detect （自动检测）——PICkit™ 2 编程器每次操作时会自动检测目标
器件有无自己的电源，或是否需要 PICkit™ 2 编程器供电。

- Force PICkit 2 （强制 PICkit 2 供电）——PICkit™ 2 编程器会始终尝试用
VDD 对目标器件供电。
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- Force Target （强制目标供电）——PICkit™ 2 编程器总是假定目标器件有自
己的电源。

• Fast Programming（快速编程）——选中时，PICkit™ 2 编程器将尝试对器件进行
快速编程。未选中时， PICkit™ 2 编程器会使 ICSP 通信变慢。这可能对 ICSP 线
带负载的目标器件有帮助。

• Check Communication （检查通信）——通过尝试用器件 ID 识别所连接的器件，
检查它与 PICkit™ 2 编程器的 USB 通信，以及与目标器件的 ICSP 通信。

• Troubleshooting（疑难解答）——打开向导，协助解决有关 PICkit™ 2 编程器与目
标器件连接的问题。这在 PICkit™ 2 编程器根本无法检测到目标器件时最有用。 

• Download PICkit™ 2 Programmer Operating System（下载 PICkit™ 2 编程器操作
系统）——下载 PICkit™ 2 单片机编程器操作系统。

HELP （帮助）

• PICkit™ 2 User’s Guide （PICkit™ 2 用户指南）——尝试启动 PICkit™ 2 User's 
Guide PDF 文件 （必须装有 Adobe Reader）

• 44-Pin Demo Board Guide （44 引脚演示板指南）——尝试启动 44-Pin Demo 
Board User's Guide PDF 文件 （必须装有 Adobe Reader） 

• LPC Demo Board Guide（LPC 演示板指南）——尝试启动 Low Pin Count Demo 
Board User's Guide PDF 文件 （必须装有 Adobe Reader）

• PICkit™ 2 Programmer on the web （PICkit™ 2 编程器网上信息）——在默认的
网络浏览器中打开 www.microchip.com/pickit2。 

• Readme （自述文件）——打开 PICkit™ 2 的 Readme.txt 文件。

• About （关于）——打开对话框，其中有 PICkit™ 2 的编程软件版本、器件文件版
本以及 PICkit™ 2 编程器固件版本。

1.6.2 器件配置

器件配置窗口显示 Device （PIC® MCU 器件）、 User ID （用户 ID）、 Configuration 
Word （配置字）和 Checksum （校验和）。此窗口中还显示 OSCCAL 和 Band Gap
（带隙），这两项仅针对有这些特性的器件。 
对于低档 （12 位内核）器件，用户必须从 Device （器件）下拉列表框中选择器件。

所有其他器件系列的器件都通过它们的器件 ID 检测，器件名会显示在 Device 行中。 

1.6.3 状态窗口

状态窗口以文本形式显示当前操作的状态。如果操作成功，则状态窗口会显示绿色背
景。如果操作失败，则状态窗口会显示红色。如果操作引起警告提示，则状态窗口会
显示黄色。

1.6.4 进度条

进度条显示操作的进度。

1.6.5 器件 VDD

可通过单击复选框 “On”（使能）打开和关闭 PICkit™ 2 编程器的 VDD。通过在右边
框中直接输入或者用上下箭头调节 （每次 1/10 伏）来设置该电压。允许的最高和最低
电压随目标器件不同而有所变化。
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PICkit™ 2 编程器概述
如果选中 “On”复选框， PICkit™ 2 编程器会在请求的任何编程操作中，自动按设置
的电压打开 VDD。

图 1-4： PICKIT™ 2 单片机编程器提供的 VDD

如果目标器件有自己的电源，则 PICkit™ 2 编程器会在右边框中显示检测到的 VDD 电
压，并灰掉以防被更改。复选框文字变为 “Check”（检查），单击该复选框会更新检
测到的 VDD 电压值。如果选择了 Target VDD > Auto-Detect，且未检测到目标电源，单
击该复选框会将 VDD 模式变回 PICkit™ 2 编程器提供的 VDD。

图 1-5： 目标器件提供的 VDD

1.6.6 存储器源

Source （源）栏显示当前装入的器件数据的来源。如果从 hex 文件读取，会显示 hex
文件的名称。如果从器件读取，会显示器件名称。 None (Empty/Erased)（无
（空 / 擦除））表示缓冲区为空，在窗口中编辑 Program Memory （程序存储器）或
EEPROM Data （EEPROM 数据）后将显示 Edited（已编辑）。

1.6.7 程序存储器

选择 File > Import HEX，可以将程序代码加载到 PICkit™ 2 编程软件中；或者单击
Read （读）按钮可以从器件中读取程序代码。代码的来源显示在 Source 框中。
Program Memory 窗口显示十六进制的程序代码。在此窗口中不能编辑代码。

Program Memory 窗口旁的复选框仅在具有 EEPROM 数据存储器的器件上提供。如果
选中该框，则程序存储器、用户 ID 和配置字将写入器件、从器件读取，并在器件上校
验。如果未选中该框，则程序存储器、用户 ID 和配置字在写器件操作中不会被擦除或
更改，也不会被读取或校验。该复选框不影响擦除器件或空白检查操作。不能同时清
除两个存储器窗口复选框。

1.6.8 数据 EEPROM 存储器

与上述的程序存储器类似，选择 File > Import HEX 可以将程序代码加载到 PICkit™ 2
编程软件中；或者单击 Read 按钮可以从器件中读取程序代码。代码的来源显示在
Source 框中。 EEPROM Data 窗口显示十六进制的程序代码。在此窗口中不能编辑代
码。

EEPROM Data 窗口旁的复选框控制读、写还是校验 EEPROM 数据存储器。如果选中
该框，则该器件的 EEPROM 将由窗口数据覆盖。如果未选中该框，则该器件的
EEPROM 在写器件操作中不会被擦除或更改。该复选框不影响擦除器件或空白检查操
作。不能同时清除两个存储器窗口复选框。
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注：
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第 2 章  入门
2.1 简介

本章介绍如何开始使用 PICkit™ 2 单片机编程器对基于闪存的 PIC® 单片机 （MCU）
进行编程。 
要了解如何通过 PICkit™ 2 单片机编程器进行在线串行编程，请参见第 3 章“PICkit™ 
2 编程器和 ICSP™”。

要了解如何更新 PICkit™ 2 编程器操作系统，请参见第 6 章 “更新 PICkit™ 2 编程器
操作系统”。

2.2 安装 PICkit™ 2 编程软件

将 PICkit™ Starter Kit CD-ROM 插入 CD-ROM 驱动器。片刻后，将显示介绍性屏幕。
按照屏幕上的指示安装 PICkit™ 2 编程软件。

如果没有出现介绍性屏幕，请浏览至 CD-ROM 目录，然后双击 AutorunPro.exe程
序。

2.3 使用 PICkit™ 2 编程软件

选择开始 > 程序 > Microchip > PICkit 2，启动 PICkit™ 2 编程软件。编程界面如图 2-1
所示。
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图 2-1： PICkit™ 2 编程软件

2.3.1 连接至器件

PICkit™ 2 单片机编程器能够对 Microchip 各种基于闪存的 PIC® 单片机进行编程。

第一次打开 PICkit™ 2 编程器软件应用程序时，会尝试按器件 ID 识别连接的器件。

要在应用程序运行后连接到某个器件，可单击如图 2-2 所示的 Device Family 菜单，选
择器件系列。 

图 2-2： 选择器件系列

2.3.2 器件识别

PICkit™ 2 单片机编程器会自动从连接的 PIC® MCU 读取器件 ID 字，并将它显示在配
置窗口中，如图 2-3 所示。任何时候都可以选择器件系列，搜索该系列中连接的器件。
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图 2-3： 识别器件

如果选择了低档 （12 位内核）闪存器件系列，则用户必须从器件下拉列表框中选择具
体器件，如图 2-4 所示。

图 2-4： 选择低档闪存器件

2.3.3 向目标器件供电

PICkit™ 2 单片机编程器可向目标器件供电。要向目标器件供电，请选中 VDD PICkit™ 
2 “On”复选框，如图 2-5 所示。

可通过调节电压框，在使能电源之前或之后调节对目标器件提供的电源。

警告

请确保选择了正确的低档闪存器件。这些器件不包含用以确认器件选择的器件 ID。如果选择了

错误的低档闪存器件，则可能会导致擦除最后一个存储单元中存储的 OSCCAL 值。

注： 启动 PICkit™ 2 单片机编程器时，向目标器件供电功能默认为关闭。

注： 如果未检测到目标电源，PICkit™ 2 单片机编程器将在编程期间始终对目标
器件供电，无论 VDD PICkit™ 2 “On”复选框状态如何。
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图 2-5： 使能向目标器件供电

如果在提供 VDD 的 PICkit™ 2 单片机编程器上检测到短路或过大的电流负载，用户将
收到如图 2-6 所示的错误，并且自动禁止 VDD。

为避免发生电流负载过大错误，建议将目标电流消耗保持在 25 mA 以下。过大的 VDD
电容也应避免，因为它们会延长 VDD 的上升时间。允许的 VDD 上升时间是 500 µs 或
更短。

图 2-6： VDD 错误

目标器件也可以从外部供电。默认情况下， PICkit™ 2 编程器会自动检测外部供电的
电路板。器件 VDD 将更新为 “VDD Target”（目标 VDD），复选框文字变为
“Check”，检测到的 VDD 电压将显示在灰掉的电压框中，如图 2-7 所示。

单击该复选框将更新电压框中显示的检测到的 VDD 电压。如果单击该复选框时未检测
到 VDD 电压，则 PICkit™ 2 编程器将恢复对目标器件提供 VDD 电源。

图 2-7： 外部供电的目标器件

警告

USB 端口电流限制设定为 100 mA。如果目标器件和 PICkit™ 2 单片机编程器的电流

之和超出此电流限制，则 USB 端口将关闭。如果目标器件需要更大电流，则可由外

部电源供电。

注： PICkit™ 2 编程器可用的最高外部 VDD 是 5.0 伏。PICkit™ 2 编程器可用的
最低外部 VDD 是 2.5 伏。
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2.3.4 导入 HEX 文件

要导入编译过的程序（hex 文件），请选择 File > Import HEX，如图 2-8 所示。浏览至
hex 文件，然后单击 Open （打开）。此时在 Program Memory 和 EEPROM Data 窗
口中显示代码。 hex 文件的名称显示在 Source 框中。

如果 hex 文件不包含任何配置字，PICkit™ 2 单片机编程器将警告用户。用户可通过在
MPLAB® IDE 中选择 File > Export 并保存 hex 文件，确保将配置字包含在 hex 文件
中。

如果 hex 文件包含当前器件中不存在的存储单元，用户也会收到指出 hex 文件大于选
定器件存储容量的警告。不存在的存储单元的任何数据都不会导入。

图 2-8： 导入 HEX 文件

2.3.5 烧写器件

选择器件系列并导入 hex 文件后，单击 Write 按钮，可对目标 PIC® MCU 进行编程。
此时将擦除 PIC® MCU 并以之前导入的 hex 代码对其编程。器件配置窗口下面的状态
条会显示 “烧写”操作的状态。

如果烧写成功，状态条会变绿并显示 “Programming Successful”（烧写成功），如
图 2-9 所示。

注： 编程前将擦除器件。PICkit™ 2 单片机编程器使用批量擦除方法，有一个最
低 VDD 要求。如果 VDD 低于所连接器件的最低工作电压值，用户将收到警
告。
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图 2-9： 烧写成功状态

如果烧写失败，状态条会变红并显示“Programming Failed”（烧写失败），如图 2-10
所示。此错误指示编程过程中数据被破坏。如果显示此错误，请重新尝试将程序烧写到
器件中。如果依然出错，请参见第 5 章“疑难解答”，以获取帮助。

图 2-10： 烧写错误状态

如果某器件有 EEPROM 数据存储器，则 Program Memory 和 EEPROM Data 旁的
“Enabled”（使能）复选框将变为可用。 
这些复选框可用于选择编程操作将影响哪些存储器区域。有关编程操作如何受这些复
选框影响的说明，请参见表 2-1。 Erase 和 Blank Check 总是针对所有存储器区域。

在 Write 操作中，器件中不受影响的区域将保留不变。

例如，如果 Program Memory 未选中而 EEPROM Data 选中，则写操作仅写入
EEPROM 数据，而器件中的程序存储器、用户 ID 和配置字都保持不变。 Erase 和
Blank Check 总是针对所有存储器区域。

如果 Program Memory 选中而 EEPROM Data 未选中，则写操作将烧写程序存储器、
用户 ID 和配置字，而器件中的 EEPROM 数据保持不变。 
请注意，由于部分器件中的编程限制， PICkit™ 2 单片机编程器应用程序会在写操作
过程中读取并重新写入 EEPROM 数据存储器，以保护其内容。 Erase 和 Blank Check
总是针对所有存储器区域。 
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两个存储器区域都不选中是不允许的。

2.3.6 自动重载文件

在每次烧写前，会将导入的 hex 文件的时间戳与磁盘上的版本进行比较。如果磁盘上
的版本更新，则重新载入此文件。只有在已经从磁盘读取 hex 文件的情况下，才有此
功能。

这个功能可确保将 MPLAB® IDE 编译的最新版本烧写到器件中。

2.3.7 校验

“校验”功能用导入的 hex 文件校验器件中的程序。此功能比较存储器的所有区域，
包括程序存储器、数据 EEPROM 存储器、 ID 和配置位。

要对代码进行校验，请导入 hex 文件并单击 Verify 按钮。如果代码相同，状态条将变
绿并显示 “Device Verified”（器件已校验）。如果发现不同，状态条将变红并显示出
错位置：“Error in Program Memory, Data EEPROM Memory, or Configuration Bits”
（程序存储器、数据 EEPROM 存储器或配置位出错）。

表 2-1 例举了校验如何受到存储器区域复选框的影响。

2.3.8 读

要查看烧写到 PIC® MCU 的代码，请单击 Read 按钮。此时在 Program Memory 和
EEPROM Data 窗口中显示代码，以供您查阅。如果显示的全都是零，则此器件可能
被代码保护了。

表 2-1 例举了读操作如何受到存储器区域复选框的影响。 

2.3.9 代码保护器件

“代码和数据保护”功能使能 PIC® MCU 的读保护功能。要保护程序存储器代码，请
完成以下步骤：

1. 导入 hex 文件。

2. 选择 Tools > Enable Code Protect，如图 2-11 所示。

3. 单击 Write。
具有 EEPROM 数据存储器的器件可通过选择 Tools > Enable Data Protect 保护它。

表 2-1： 存储器区域选择

程序存储器使能 EEPROM 数据使能 写 / 读 / 校验 擦除 / 空白检查

选中 选中 所有存储器区域 所有存储器区域

选中 — 程序存储器
用户 ID
配置字

所有存储器区域

— 选中 仅限 EEPROM 所有存储器区域

— — 不允许
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图 2-11： 使能代码保护

2.3.10 擦除

擦除功能会擦除程序存储器、数据 EEPROM 存储器、 ID 和配置位，无论 Program 
Memory 和 EEPROM Data “Enabled”复选框状态如何。但是，一般情况下不需要此
功能，因为 “烧写”功能在对 PIC® MCU 进行编程之前就已执行了擦除操作。

要擦除器件，请单击 Erase 按钮。

2.3.11 空白检查

空白检查功能会读整个器件，判断程序存储器、 EEPROM 数据存储器、用户 ID 和配
置位是否已擦除。所有存储器区域都会检查，无论 Program Memory 和 EEPROM 
Data “Enabled”复选框状态如何。

2.3.12 Auto Import Hex + Write Device 按钮

该功能允许 PICkit™ 2 编程器在 hex 文件更新时 （例如重新编译了固件时）自动导入
hex 文件，并将它写入连接的器件。

要使用该功能，单击 Auto Import Hex + Write Device 按钮，如图 2-12 所示。这将打
开 Import Hex file 对话框，默认选择为“File”菜单下文件历史记录中的第一个 hex 文
件。选择文件后，它会被写入器件中。现在 PICkit™ 2 单片机编程器会监视选定的 hex
文件有无更新。该文件更新时 （有更新的时间戳）， PICkit™ 2 单片机编程器会自动
重新导入 hex 文件，并写入目标器件。

该功能使能时，其他编程操作被禁止。Auto Import Hex + Write Device 按钮在该功能
激活时会保持按下状态，如图 2-13 所示。要停止使用该功能，再次单击 Auto Import 
Hex + Write Device 按钮即可。

如果导入 hex 文件或器件编程期间遇到错误，则 PICkit™ 2 单片机编程器会自动退出
该功能模式。

注： 如果读取已被保护的器件，受保护的存储器区域显示的全都是零。

注： PICkit™ 2 单片机编程器使用批量擦除方法，有一个最低 VDD 要求。如果
VDD 低于所连接器件的最低工作电压值，用户将收到警告。
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图 2-12： AUTO IMPORT HEX + WRITE DEVICE 按钮

图 2-13： 自动导入 + 写功能激活

2.3.13 Read Device + Export Hex File 按钮

单击该按钮时会读目标器件，并打开 Export Hex File 对话框。
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注：
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第 3 章  PICkit™ 2 编程器和 ICSP™ 
3.1 简介

PICkit™ 2 单片机编程器可以对安装在应用电路中的 PIC® 单片机进行在线串行编程
（ICSP™）。在线串行编程 （ICSP）需要五个信号：

• VPP——编程电压；施加此电压时，器件进入编程模式。

• ICSPCLK/PGC——编程时钟；编程器到目标器件的单向同步串行时钟线。

• ICSPDAT/PGD——编程数据；双向同步串行数据线。

• VDD——电源正电压。

• VSS——电源参考地。

但是，必须将应用电路设计为允许所有编程信号连接至 PIC 单片机器件，而不会干扰
编程信号。图 3-1 显示了一个典型电路，设计 ICSP 应用电路时，可以此电路为起点。
要成功实现 ICSP 编程，必须遵守以下各节中的注意事项。

图 3-1： 典型的 ICSP™ 应用电路

注： 要详细了解如何对具体器件进行编程，请参见 Microchip 网站
www.microchip.com 提供的器件编程规范。

  1
  2
  3
  4
  5
  6

VPP/MCLR
VDD
VSS
ICSPDAT/PGD
ICSPCLK/PGC
AUX

目标单片机器件

470Ω*

0.1 µF*

  1
  2
  3
  4

VDD
RA5

VSS

RA4
RA3/MCLR/VPP

  8
  7
  6
  5

PICkit™ 2

+5V

或

+5V

至应用

电路

隔离电路：

电阻或肖特基二极管

编程插头

10k*

*  典型值

RA0/ICSPDAT
RA1/ICSPCLK

RA2
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3.2 隔离 VPP/MCLR/ 端口引脚

施加 VPP 电压时，必须考虑到应用电路中的典型 VPP 电压为 +12V。在下列情况下，
这可能是一个需要考虑的问题：

3.2.1 将 VPP 引脚用作 MCLR 引脚时

根据器件数据手册的建议，应用电路一般与一个上拉电阻 / 电容电路连接。注意不要使
VPP 电压的变化率变慢，而使其超出编程规范中规定的上升时间 （通常为 1 µs）。

如果在 MCLR 引脚连接监控电路或按钮，建议使用肖特基二极管或限流电阻将它们与
VPP 电压隔离，如图 3-1 所示。有关配合 ICSP 使用监控电路的更多信息，请参见应用
笔记 AN820 “System Supervisors in ICSP™ Architectures”（DS00820）。

3.2.2 将 VPP 引脚用作 I/O 端口引脚时

连接到 I/O 引脚的应用电路可能无法处理 +12V 电压。建议如图 3-1 所示使用肖特基二
极管或限流电阻来隔离此电路。

3.3 隔离 ICSPCLK/PGC 和 ICSPDAT/PGD 引脚

必须将 ICSPCLK/PGC 和 ICSPDAT/PGD 引脚与应用电路隔离，以防止应用电路影响
编程信号。 ICSPCLK/PGC 是编程器到目标器件的单向同步串行编程时钟线。
ICSPDAT/PGD 是双向同步串行编程数据线。

如果设计时允许，请将这些引脚专用于 ICSP。但是，如果应用电路需要使用这些引
脚，就请采用不会改变信号电平和电压变化率的方式来设计电路。根据不同的应用，
隔离电路会有所差异。图 3-1 显示了其中一种隔离电路，它使用串联电阻将 ICSP 信号
与应用电路隔离。
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3.4 VDD

在 ICSP 编程过程中，必须根据器件规范对 PIC® MCU 供电。一般情况下，将 PIC® 
MCU 的电源连接到应用电路的电源。应用电路可由 PICkit™ 2 单片机编程器或外部电
源供电。需要注意以下几种情况。

3.4.1 应用电路由 PICkit™ 2 单片机编程器供电

PICkit™ 2 单片机编程器的供电电压可在器件编程规范允许的最高和最低电压之间设
置，但最低电压不得低于 +2.5V。对器件编程或打开 VDD 之前一定要将电压框设置为
适当的电压。

3.4.2 应用电路由外部电源供电

PICkit™ 2 单片机编程器可与由外部 +2.5V 到 +5.0V 电源供电的应用电路一起使用。

3.4.3 使用批量擦除时

某些 PIC® MCU 器件使用批量擦除功能来擦除程序存储器、数据 EEPROM 存储器、
ID 单元和配置位。一般情况下，批量擦除功能要求的电源电压 （VDD）为 4.5 到 5.5 V
（有关器件的具体要求，请参见器件编程规范）。 
如果将应用电路设计为在不同的电源电压范围内工作，则上述电压范围可能会产生问
题。为了批量擦除 PIC® MCU，在保护所有电压敏感电路的同时，还必须在应用电路
中考虑到批量擦除电压要求。 

警告

USB 端口电流限制设定为 100 mA。如果目标器件和 PICkit™ 2 单片机编程器的电流

之和超出了此电流限制，则 USB 端口将关闭。如果目标器件需要更大电流，则可由

外部电源供电。

注： 使用 PICkit™ 2 单片机编程器对应用电路供电时，消耗的电流应限于 25 mA。
要保证应用电路不会使 VDD 上升时间长于 500 µs。
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3.5 VSS

VSS 为电源的参考地，必须与应用电路同电位。

3.6 其他注意事项

最大限度缩短 ICSP 信号的传输距离，方法是尽可能使 ICSP 连接器靠近应用电路中
PIC® MCU。最大限度缩短 PICkit™ 2 单片机编程器和应用电路中 PIC® MCU 之间的
电缆长度。这样做的目的是使 ICSP 信号保持在电平和电压变化率规范的要求之内，
从而实现成功编程。
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第 4 章  PICkit™ 2 Debug Express
4.1 简介

PICkit™ 2 单片机编程器允许对选定 PIC® 单片机（MCU）进行在线调试。在线调试允
许设计人员在硬件中嵌入 PIC® MCU 后运行、检查和修改程序。这大大方便了设计人
员同时调试固件和硬件。 
Debug Express 软件与 MPLAB® IDE 软件相互作用，可运行、停止和单步运行程序。
可设置一个断点，也可以将处理器复位。处理器停止后，可检查和修改寄存器的内容。

4.1.1 支持的器件

PICkit™ 2 Debug Express 当前支持的器件列表，请参见 MPLAB® IDE 安装目录的
Readmes 子目录中的 “Readme for PICkit 2.htm”文件。

4.1.2 PICkit™ 2 Debug Express 使用的资源

由于 ICD 器件的内置在线调试功能和调试器提供的 ICSP 功能， PICkit™ 2 Debug 
Express 会在调试时使用一些片上资源。

中档器件的常规资源

• MCLR 引脚是为调试保留的；调试时该引脚不能用作数字 I/O。

• MCLR/VPP 编程时共用。

• ICSPDAT 和 ICSPCLK 端口引脚是为编程和在线调试保留的。因此，这些引脚上复
用的其他功能在调试期间将不可用。

• 一层堆栈不可用。

程序和数据存储器资源

PICkit™ 2 Debug Express 在调试期间使用目标器件中的程序存储器和文件寄存器单
元。用户代码不能使用这些存储单元。在 MPLAB IDE 中，寄存器显示中标有 “R”的
寄存器代表保留的寄存器。

注： Debug Express 需要 MPLAB® IDE 7.50 版或更高版本。 

注： Debug Express 要求在 ICSPCLK 和 ICSPDAT 引脚上接 4.7 kΩ 的下拉电
阻。较新的配有红色按钮的 PICkit™ 2 单片机编程器内置了下拉电阻。较
早的配有黑色按钮的 PICkit™ 2 单片机编程器需要在目标电路板上添加下
拉电阻。
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关于具体器件的保留存储单元，请参见 MPLAB® IDE 中的 MPLAB® ICD 2 帮助。在
MPLAB® IDE 中，选择菜单 Help > Topics…。在 Help Topics （帮助主题）对话框的
“Debuggers”（调试器）下，选择 “MPLAB® ICD 2”并单击 OK （确定）。在
MPLAB® ICD 2 Help （MPLAB® ICD 2 帮助）对话框中，选择 “Contents”（内容）
选项卡下的 “Operation”（操作）。选择 “MPLAB® ICD 2 Overview”（MPLAB® 
ICD 2 概述），然后选择 “Resources Used By MPLAB® ICD 2”（MPLAB® ICD 2 使
用的资源）。将显示器件系列的列表。选择感兴趣的器件系列可了解更多关于保留的器
件资源的信息。

还可以参考以下文档：

• MPLAB® ICD 2 在线调试器用户指南 （DS51331C_CN）

4.2 PICkit™ 2 DEBUG EXPRESS
本节说明如何用 PICkit™ 2 Debug Express 调试程序。这些内容适用于那些不熟悉程
序调试，但熟悉 MPLAB® IDE 软件的人员。

有关如何使用 MPLAB® IDE 软件的更多信息，请参见以下文档：

• MPLAB® IDE 用户指南 （DS51519A_CN）

• MPLAB® IDE 快速入门指南 （DS51281G_CN）

• MPLAB® IDE 在线帮助

4.2.1 选择器件和开发模式

从 MPLAB® IDE 菜单栏中，为本教程选择 PIC® MCU 器件： 
1. 选择 Configure > Select Device。

图 4-1： MPLAB® IDE 菜单栏

2. 单击 Device 下拉列表，选择 PIC16F887 器件。此对话框中无需做其他更改。

3. 单击 OK。
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图 4-2： 选择器件

4.2.2 PICkit™ 2 单片机编程器调试工具

选择 PICkit™ 2 单片机编程器作为调试工具：

• 选择 Debugger > Select Tool > PICkit 2。
Output （输出）窗口将显示 PICkit™ 2 单片机编程器和目标电路板之间的通信状
态，如图 4-4 所示。

图 4-3： PICkit™ 2 调试工具
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图 4-4： OUTPUT 窗口

4. 选择 Debugger > Settings 设置 PICkit™ 2 操作。 
5. 单击 “Connect on Startup”（启动时连接）复选框使能自动连接功能。

6. 单击 OK。 

图 4-5： PICkit™ 2 设置
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7. 选择 Debugger > Connect 连接到 PICkit™ 2。 Output 窗口将显示 PICkit™ 2 和
目标电路板之间的通信状态。

图 4-6： PICkit™ 2 单片机编程器连接

4.2.3 更新 PICkit™ 2 固件 （操作系统）

根据 MPLAB® IDE 软件或选定器件的版本，可能会显示一条消息，指出固件需要更
新。 MPLAB® IDE 会自动安装新的固件 （见图 4-7）。 

图 4-7： 更新 PICkit™ 2 FIRMWARE 对话框

4.2.4 运行 Project Wizard
对于该项目，将使用 MPASM™ 汇编器工具：

1. 选择 Project > Project Wizard 设置第一个项目。将显示 Project Wizard（项目向
导）的欢迎菜单。 

2. 单击 Next （下一步）继续第一步。 
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图 4-8： PROJECT WIZARD

3. 从 Device 下拉框中选择 PIC16F887 器件。

4. 单击 Next 继续第二步。

图 4-9： 第一步 

5. 从 Active Toolsuite （有效工具包）下拉菜单中选择 “Microchip MPASM 
Toolsuite”。

6. 单击 Next 继续第三步。

确保工具设置为正确的可执行文件，默认在 C:\Program 
Files\Microchip\MPASM Suite文件夹中，如下： 

•  MPASM 汇编器应指向 mpasmwin.exe
•  MPLINK 链接器应指向 mplink.exe
•  MPLIB 库管理器应指向 mplib.exe
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图 4-10： 第二步

• 在第三步中输入项目的名称和位置，或单击 Browse （浏览）按钮查找项目文件。

• 单击 Next 继续第四步。

图 4-11： 第三步

在第四步中添加项目文件： 
从左边窗格中转到 C:\Program Files\Microchip\PICkit 2 v2\DBE Demo。
选择并高亮显示 16F887Demo.asm文件，然后单击 Add （添加）按钮。该文件将被
放入右边窗格中。

7. 单击该文件旁的复选框将该文件复制到项目目录中。

8. 单击 Next 继续，转到 Summary （摘要）窗口。 

注： 如果需要可在以后添加文件。
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图 4-12： 添加文件

如果发生任何错误，单击 Back （上一步）按钮可返回到项目向导中以前的任何一个
步骤。单击 Finish （完成）。 

图 4-13： 项目摘要

4.2.5 PIC16F887 调试演示项目

完成项目设置并退出 Project Wizard 后，将在 MPLAB® IDE 桌面窗口中显示项目窗
口，如图 4-14 所示。
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图 4-14： 项目窗口

如果需要，可以用项目窗口向项目添加其他文件。右键单击项目窗口树中的任何文件
或文件夹，可显示具有更多用于添加或删除文件的选项的弹出窗口。 

图 4-15： 添加和删除文件

4.2.6 创建 Hex 文件

选择 Project > Build All，或右键单击项目窗口中的项目名称，然后从弹出菜单中选择
“Build All”（编译全部）。 MPASM 汇编器将生成文件名和 .asm 源文件名相同的 hex
文件。

图 4-16： 编译项目
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图 4-17： OUTPUT 窗口

4.2.7 设置调试选项

开始调试前必须选择器件的配置位。 

4.2.7.1 配置位

要烧写到器件中的配置位是在程序中设置的。这些位可以用 Configuration Bits （配置
位）对话框窗口检查。

• 选择 Configure > Configuration Bits。
• 要更改某配置位的设置，双击 “Setting”（设置）栏中的文字，为相应配置位类
选择正确设置。

对于本教程，必须设置以下配置位： 
Config1：
• Oscillator – Internal RC No Clock （振荡器——内部 RC，无时钟）

• Watchdog Timer – Off （看门狗定时器——关）

• Power-Up Timer – On （上电延时定时器——开）

• Master Clear Enable – MCLR is external（主复位使能——MCLR 是外部复位输入
引脚） 

• Code-Protect – Off （代码保护——关）

• Data EE Protect – Off （数据 EE 保护——关）

• Brown-Out Detect – BOD and SBOREN Disabled （欠压检测——BOD 和
SBOREN 被禁止）

• Internal-External Switch Over Mode – Disabled （内 / 外部切换模式——禁止）

• Monitor Clock Fail-safe – Disabled （故障保护时钟监视器——禁止）

• Low-Voltage Program – Disabled （低电压编程——禁止）

Config2：
• Self Write Enable – No Protection （自写使能——无保护）

• Master Brown-out Reset Sel Bit – Brown-out at 2.1V （主欠压复位设置位——
2.1V 欠压复位）
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图 4-18： 配置位设置

4.2.8 载入程序代码进行调试

• 选择 Debugger > Select Tool > PICkit 2，选择 PICkit™ 2 单片机编程器作为调试工
具。 

• 选择 Debugger > Program 将 16F887Demo.asm文件烧写到 44 引脚演示板上的
PIC16F887。

图 4-19： 烧写代码以进行调试

烧写只需几秒钟。烧写期间， Output 对话框窗口的 PICkit™ 2 选项卡将显示操作的当
前进度。完成后，对话框看上去就像图 4-20。

注： 对于 PICkit™ 2 调试功能，调试执行代码自动烧写到 PIC16F887 （目标器
件）程序存储器的高地址区。必须将调试代码烧写到目标 PIC® MCU，才
能使用 PICkit™ 2 编程器的在线调试功能。
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图 4-20： OUTPUT 窗口——PICkit™ 2 选项卡

4.2.9 PIC16F887 调试演示

PICkit™ 2 单片机编程器可在实时模式或单步模式下执行。 44 引脚演示板上的
PIC16F887 处于 MPLAB® IDE 的运行模式时，以实时模式执行。处理器暂停后以单步
模式执行。 
以下工具栏按钮可用于快速访问常用调试操作：

4.2.9.1 实时模式

打开 16F887Demo.asm文件：

1. 在项目窗口中双击 16F887Demo.asm文件，或从工具栏菜单选择 File > Open。 
2. 选择 Debugger > Run，或单击 Run 按钮。

3. 旋转位于演示板上的电位器 （RA0），观察 LED。

如果程序运行正常， LED 会根据电位器旋转方向闪烁得更快或更慢。但是，为了演示
调试，故意在代码中加入了错误。关于调试的说明，请参见下一节第 4.2.10 节 “调试
PIC16F887 调试演示代码”。

4. 选择 Debugger > Halt，或单击 Halt 按钮可停止程序的执行。

5. 选择 Debugger > Reset 可将程序复位。

调试器菜单 工具条按钮

Run （运行）

Halt （暂停）

Animate （连续单步运行）

Step Into （单步运行）

Step Over （单步跳过）

Step Out （单步跳出）

Reset （复位）
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4.2.10 调试 PIC16F887 调试演示代码

以下任何问题都可能使 PIC16F887 调试演示程序无法正常运行： 
• A/D 转换器值未正确写入延时子程序。

• A/D 转换器未使能，或者未设置为进行转换。

• 源代码中的输入错误使程序运行不正确。

要找出上述第一种可能发生的问题，可在将 A/D 结果值写入延时高位字节的代码行设
置断点：

1. 将光标置于 16F887Demo.asm文件中的以下代码行： 
movwf Delay+1，如图 4-21 所示。
程序会在完成 A/D 转换后停在该断点处。

2. 右键单击可显示下拉菜单。

3. 从下拉菜单中选择 Set Breakpoint （设置断点）。 
程序会给该行标记上红色八边形外框的字母 B，如图 4-21 所示。 

图 4-21： 断点

4. 选择 Debugger > Run，或单击 Run 按钮以在实时模式下运行程序。
程序执行到标记为断点的那行时，断点会停止程序的执行。 

5. 将鼠标移到列表文件中的“ADRESH”，它会显示文件寄存器的值（见图 4-22）。
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图 4-22： ADRESH 寄存器值

6. 调节电位器，选择 Debug > Run 继续运行程序。程序会运行循环，然后暂停。 
7. 再次将鼠标移到 “ADRESH”上，发现 A/D 结果未变。这样看来 A/D 转换未起

作用。 A/D 转换的初始化和设置发生在程序开始时。

图 4-23： 程序已暂停

8. 选择 Debugger > Reset 可将程序复位。第一条指令应标有绿色箭头。

9. 选择 View > Watch 打开新的 Watch （观察）窗口。用户可通过该窗口观察程序
执行时 A/D 寄存器值的变化。 Watch 对话框打开时选中了 Watch_1 选项卡，如
图 4-24 所示。 
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图 4-24： WATCH 窗口

10. 选择 ADCON0 并单击 Add SFR （添加特殊功能寄存器）按钮将 ADCON0 添加
到 Watch 窗口。

11. 重复步骤 10 将 ADCON1 和 ADRESH 添加到 Watch 窗口。选定的 SFR 应在
Watch 窗口中可见，如图 4-25 所示。

图 4-25： 添加 SFR

12. 选择 Debugger > Run 在实时模式下运行该程序。这次程序会在执行断点代码行
后停止，并标示出断点后的那条指令，如图 4-26 所示。

图 4-26： 程序中断后暂停
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13. 在 Watch 窗口中检查 ADCON0 和 ADCON1 寄存器的值。 ADCON0 的值是
“0x40”（b’01000000’）。这对应于程序中指定的十六进制值。但是，这是不
对的。 回顾 《PIC16F882/883/884/886/887 数据手册》（DS41291D_CN）的模
数 （Analog-to-Digital， A/D）转换器模块一节，指出要启动 A/D 模块，最后一
位应该是 1（b’01000001’）。要解决这个问题，可将：
“movlw 0x40”
改为
“movlw 0x41”，如图 4-27 所示。

图 4-27： A/D 模块代码

14. 选择 File > Save 保存更改。

15. 选择 Project > Build All 重新编译项目。会显示一条消息指出程序已重新编译。
PICkit™ 2 编程器再编程后更改才会生效。

16. 选择 Debugger > Program 用这些更改对 PICkit™ 2 编程器进行再编程。
PICkit™ 2 编程器对话框指示 “Programming Succeeded”时，就可以再次运
行程序了。

17. 右键单击以前有断点的代码行，选择 Remove > Breakpoint。
18. 选择 Debugger > Run 在实时模式下运行该程序。旋转电位器 （RA0）更改

LED 上显示的值。 
本教程中的源代码只包含一个错误。但是，实际代码可能会有更多错误。用户可以用
PICkit™ 2 编程器和 MPLAB® IDE 调试功能顺利地查找和修正代码中的问题。

4.2.11 烧写应用程序

程序成功调试并运行后，下一步就是烧写 PIC® MCU 使之在最终设计中独立操作。此
时， ICD 保留的资源会被应用程序释放出来供使用。要烧写应用程序，请执行以下步
骤： 
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1. 选择 Debugger > Select Tool > None，禁止将 PICkit™ 2 编程器用作调试工具。

2. 在 Programmer > Select Tool 菜单中选择 PICkit™ 2 编程器作为编程器。

3. 可选：在 Configure > ID Memory 中设置 ID。

图 4-28： CONFIGURE——ID MEMORY

图 4-29： USER ID MEMORY

4. 在 Programmer > Settings Program 选项卡上设置编程参数。

5. 选择 Programmer > Program。

现在 PICkit™ 2 编程器可以复位并运行目标器件了。
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注：
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第 5 章  疑难解答
5.1 简介

本章介绍使用 PICkit™ 2 单片机编程器时遇到的常见问题及解决方法。

5.2 常见问题

未识别到器件

问题

为什么会接收到 “No Device Found”消息？

回答

请验证是否支持该器件，并且目标 MCU 是否已根据第 3 章“PICkit™ 2 编程器和
ICSP™”的说明连接至 PICkit™ 2 单片机编程器。根据器件数据手册，确认
PIC18F_J_、 PIC24 和 dsPIC33 器件在 VDDCORE/VCAP 引脚上接有适当的电容。

电流超出限制

问题

为什么会在 Microsoft® Windows® 程序中接收到错误消息 “USB Hub Current Limit 
Exceeded”？

回答

检查应用电路从 PICkit™ 2 编程器中消耗的电流是否超过 25 mA。

Microsoft® Windows® 驱动程序

问题

将 PICkit™ 2 单片机编程器插到 USB 端口后， Windows® 98 SE 请求提供驱动程序。
驱动程序在哪里？

回答

PICkit™ 2 单片机编程器使用包含在 Windows® 操作系统中的驱动程序。当 Windows® 
98 SE 请求提供驱动程序时，请选择 “搜索设备的最新驱动程序”，然后选择
“Microsoft Windows Update”旁边的复选框并单击“下一步”。Windows 将自动安装
相应的驱动程序。请勿使用 Microchip 的 ICD 2 USB 驱动程序。

校验和读取时返回的内容都是零

问题

单击 Verify 或 Read 按钮时， Program Memory 窗口显示的都是零。问题出在哪里？

回答

器件可能被代码保护了。请确保在 Configuration Word 中没有选择代码保护。
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Microsoft® Windows® 95/98/NT

问题

是否可以在 Windows® 95/98/NT 上运行？

回答

不可以。这些操作系统或者不支持 USB，或者驱动程序与本产品不兼容。

VDD/VPP 错误

问题

为什么我总是收到 “VDD Error”或 “VPP Error”？

回答

该错误表示 PICkit™ 2 编程器无法将 VDD 或 VPP 驱动至目标电压。请检查电路板上有无
短路或很大的电流消耗，并确认目标 MCU 连接到 PICkit™ 2 编程器的方式符合第 3 章
“PICkit™ 2 编程器和 ICSP™”。确保 VDD 电容不会使 VDD 上升时间长于 500 µs。

编程错误

问题

为什么我只能对部分器件编程？

回答

如果部分器件配置为低电压编程，则悬空的 PGM 引脚会妨碍编程。编程时，可用电阻
将该引脚拉为低电平。

部分中档器件，如 PIC16F72、73、74、76、77 系列和 PIC16F737、747、767、777
系列有一个最低 +4.75V 的编程 VDD 要求。根据 USB 电压， PICkit™ 2 单片机编程器
可能无法在 VDD 上提供 +4.75V 电压。可用外部的 +5.0V 电源对这些器件编程。

部分 PIC18F 器件要求 VDD 上有较大的旁路电容。试将总旁路电容增加到 10 uF。
PIC18F_J_ 器件、PIC24 和 dsPIC® DSC 器件要求 VDDCORE/VCAP 引脚上有 4.7 uF
的电容才能正常工作。如果未使用独立稳压器提供 VDDCORE，要确保 ENVREG 引脚
连接到 VDD。

Debug Express 的连接问题

问题

使用 PICkit™ 2 编程器作为调试器时，对器件编程过程中我经常收到错误消息
“Unable to Enter Debug Mode”。问题出在哪里？

回答

调试中， ICSPCLK 和 ICSPDAT 信号线必须与应用中的其他电路完全隔离。有黑色按
钮的 PICkit™ 2 单片机编程器要求在 ICSPCLK 和 ICSPDAT 与 GND 之间都接入 4.7 kΩ
的下拉电阻。较新的配有红色按钮的 PICkit™ 2 单片机编程器内置了下拉电阻。
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第 6 章  更新 PICkit™ 2 编程器操作系统
6.1 简介

本章介绍如何更新 PICkit™ 2 单片机编程器的操作系统。

6.2 更新 PICkit™ 2 单片机编程器

要更新 PICkit™ 2 单片机编程器操作系统，请完成以下步骤。

第 1 步 从 Microchip 网站 www.microchip.com 下载最新的 PICkit™ 2 单片机编程
器操作系统。

第 2 步 在菜单中选择 Tools > Download PICKit 2 Operating System，如图 6-1 所
示。

图 6-1： 下载 PICkit™ 2 编程器操作系统

第 3 步 浏览至保存最新操作系统代码的目录，如图 6-2 所示。
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图 6-2： 打开 PICkit™ 2 编程器操作系统

第 4 步 选择 PK2*.hex文件并单击 Open 按钮。

操作系统 （OS）的更新进度将显示在编程软件的状态条中，同时 PICkit™ 2 单片机编
程器上的 Busy LED 将闪烁。成功完成更新后，状态条将显示 “Operating System 
Verified”，同时 Busy LED 熄灭。此时操作系统更新完成。
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附录 A 硬件原理图
A.1 简介

本附录包含 PICkit™ 2 单片机编程器的原理图。

图 A-1： PICkit™ 2 单片机编程器原理图 （第 1 页，共 2 页）
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图 A-2： PICkit™ 2 单片机编程器原理图 （第 2 页，共 2 页）
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硬件原理图

注：
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